]> git.pld-linux.org Git - packages/php.git/commitdiff
version php apache module.
authorElan Ruusamäe <glen@delfi.ee>
Wed, 23 Jan 2013 16:12:12 +0000 (18:12 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 23 Jan 2013 16:35:05 +0000 (18:35 +0200)
making it easier to "switch" php versions (force install and replace
symlink) having multiple mod_php packages installed

php.spec

index e4938a6716ac8821025ce3278521e1fc4c279da9..edfe882c304129677bab57e3b2f3847e1ec94323 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2395,11 +2395,15 @@ ln -sfn phar.phar $RPM_BUILD_ROOT%{_bindir}/phar
 # install Apache1 DSO module
 %if %{with apache1}
 libtool --mode=install install -p sapi/apache/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache1
+mv $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5{,-%{version}}.so
+ln -s libphp5-%{version}.so $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5.so
 %endif
 
 # install Apache2 DSO module
 %if %{with apache2}
 libtool --mode=install install -p sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache
+mv $RPM_BUILD_ROOT%{_libdir}/apache/libphp5{,-%{version}}.so
+ln -s libphp5-%{version}.so $RPM_BUILD_ROOT%{_libdir}/apache/libphp5.so
 %endif
 
 # install litespeed sapi
@@ -2671,6 +2675,7 @@ fi
 %dir %{_sysconfdir}/apache.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache.ini
 %attr(755,root,root) %{_libdir}/apache1/libphp5.so
+%attr(755,root,root) %{_libdir}/apache1/libphp5-%{version}.so
 %endif
 
 %if %{with apache2}
@@ -2680,6 +2685,7 @@ fi
 %dir %{_sysconfdir}/apache2handler.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
 %attr(755,root,root) %{_libdir}/apache/libphp5.so
+%attr(755,root,root) %{_libdir}/apache/libphp5-%{version}.so
 %endif
 
 %if %{with litespeed}
This page took 0.587666 seconds and 4 git commands to generate.