]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 11; fix for bug 48619 (imap segfaults)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 19 Aug 2009 09:41:51 +0000 (09:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-bug-48619.patch -> 1.1.2.1
    php.spec -> 1.805.2.6

php-bug-48619.patch [new file with mode: 0644]
php.spec

diff --git a/php-bug-48619.patch b/php-bug-48619.patch
new file mode 100644 (file)
index 0000000..2bca061
--- /dev/null
@@ -0,0 +1,40 @@
+commit 19db2c409fce51c612ce673550b186163c6e72d6
+Author: pajoye <pajoye@c90b9560-bf6c-de11-be94-00142212c4b1>
+Date:   Mon Jun 22 20:42:04 2009 +0000
+
+    - MF53: #48619, imap_search ALL segfaults
+    
+    
+    git-svn-id: http://svn.php.net/repository/php/php-src/branches/PHP_5_2@282598 c90b9560-bf6c-de11-be94-00142212c4b1
+
+diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
+index ea4e8d5..24111e1 100644
+--- a/ext/imap/php_imap.c
++++ b/ext/imap/php_imap.c
+@@ -2670,7 +2670,7 @@ PHP_FUNCTION(imap_sort)
+       slst = mail_sort(imap_le_struct->imap_stream, (myargc == 6 ? Z_STRVAL_PP(charset) : NIL), spg, mypgm, (myargc >= 4 ? Z_LVAL_PP(flags) : NIL));
+-      if (spg) {
++      if (spg && !(flags & SE_FREE)) {
+               mail_free_searchpgm(&spg);
+       }
+@@ -3712,7 +3712,7 @@ PHP_FUNCTION(imap_search)
+       mail_search_full(imap_le_struct->imap_stream, (argc == 4 ? Z_STRVAL_PP(charset) : NIL), pgm, flags);
+-      if (pgm) {
++      if (pgm && !(flags & SE_FREE)) {
+               mail_free_searchpgm(&pgm);
+       }
+@@ -4341,7 +4341,7 @@ PHP_FUNCTION(imap_thread)
+       pgm = mail_criteria(criteria);
+       top = mail_thread(imap_le_struct->imap_stream, "REFERENCES", NIL, pgm, flags);
+-      if (pgm) {
++      if (pgm && !(flags & SE_FREE)) {
+               mail_free_searchpgm(&pgm);
+       }
index 05a4456a1d2bd5052e47437221f33ae45373d8e3..667dbf2314dc4ff1b3b2695a6602d5a361de4d00 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -94,7 +94,7 @@ Summary(ru.UTF-8):    PHP Версии 5 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
 Version:       5.2.10
-Release:       10
+Release:       11
 Epoch:         4
 License:       PHP
 Group:         Libraries
@@ -162,6 +162,7 @@ Patch46:    %{name}-imap-myrights.patch
 Patch47:       suhosin.patch
 Patch48:       %{name}-bug-48697.patch
 Patch49:       %{name}-m4-divert.patch
+Patch50:       %{name}-bug-48619.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1677,6 +1678,7 @@ done
 %endif
 %patch48 -R -p3
 %patch49 -p1
+%patch50 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
This page took 0.136538 seconds and 4 git commands to generate.