]> git.pld-linux.org Git - packages/php.git/commitdiff
- updated to 7.1.25 auto/th/php71-7.1.25-1
authorAdam Gołębiowski <adamg@pld-linux.org>
Thu, 6 Dec 2018 15:07:06 +0000 (16:07 +0100)
committerAdam Gołębiowski <adamg@pld-linux.org>
Thu, 6 Dec 2018 15:07:06 +0000 (16:07 +0100)
bug-52078-fileinode.patch
pcre-shared.patch
php-link-libs.patch
php-pear.patch
php.spec
spl-shared.patch

index 0fd016326bb1f7ddddf78907c28fd3aefb2dce0e..419be68ad1481ec5b560928a3e5e8e171a3bead6 100644 (file)
@@ -72,7 +72,7 @@
 @@ -30,17 +30,17 @@
  echo "Done\n";
  ?>
- --EXPECTF--   
+ --EXPECTF--
 +int(%i)
  int(%d)
  int(%d)
index ae69ebdac93a52951525ebdc4f3020d14b6a2c5d..f0b86dc212e6dd1ea9a26f11ef73e06993f751c4 100644 (file)
@@ -24,7 +24,7 @@
  
 -    PHP_ADD_LIBRARY_WITH_PATH(pcre, $PCRE_LIBDIR)
 +    PHP_ADD_LIBRARY_WITH_PATH(pcre, $PCRE_LIBDIR, PCRE_SHARED_LIBADD)
-     
      AC_DEFINE(HAVE_PCRE, 1, [ ])
      PHP_ADD_INCLUDE($PCRE_INCDIR)
 -    PHP_NEW_EXTENSION(pcre, php_pcre.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
index 23a7acc0073fe62566c735c7b013cdf48dba450a..7a1695307ae76c9ae3671c93f7749e3e9975934e 100644 (file)
@@ -17,7 +17,7 @@
 -  save_old_LDFLAGS=$LDFLAGS
 +  save_old_LIBS=$LIBS
    ac_stuff="$5"
-   
    save_ext_shared=$ext_shared
    ext_shared=yes
 -  PHP_EVAL_LIBLINE([$]ac_stuff, LDFLAGS)
index 400359d4e47458f60ab22f71a7c7315f1ddc303c..df48f6c805828453eec687bd8e2e39e104e33444 100644 (file)
    dnl PEAR dependancies
    dnl
 -  if test "$PHP_XML" = "no"; then
--    pear_error_msg="$pear_error_msg 
+-    pear_error_msg="$pear_error_msg
 -                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
 -  fi
 -
 +dnl  if test "$PHP_XML" = "no"; then
-+dnl    pear_error_msg="$pear_error_msg 
++dnl    pear_error_msg="$pear_error_msg
 +dnl                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
 +dnl  fi
 +dnl
  dnl
  dnl  if test "$PHP_XMLRPC" = "no"; then
- dnl    pear_error_msg="$pear_error_msg 
+ dnl    pear_error_msg="$pear_error_msg
 --- php-5.2.6/sapi/cli/config.m4~      2008-11-16 18:35:31.000000000 +0200
 +++ php-5.2.6/sapi/cli/config.m4       2008-11-20 19:04:12.585061299 +0200
 @@ -4,7 +4,7 @@
index 028e38e460502c430e902d677270e9e6c5eab680..3d18d92e780e3cd50b4bdce06ec13b79989cc472 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -150,7 +150,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.1.23
+Version:       7.1.25
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -159,7 +159,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 5e5baa60cfd85dd70bed9e740dd6dbc6
+# Source0-md5: 5540e0c6cc29ed743bcca8ab6d1381c9
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
index cf0fc4ed436bb2e539d6ffded83048d00534063c..a89096b638720625172de281fbfbeff1c909712f 100644 (file)
@@ -1,9 +1,9 @@
 --- php-7.0/ext/spl/config.m4~ 2015-05-21 17:57:06.000000000 +0300
 +++ php-7.0/ext/spl/config.m4  2015-05-23 11:25:19.609715006 +0300
-@@ -22,6 +22,6 @@
-   CPPFLAGS=$old_CPPFLAGS
-   AC_DEFINE_UNQUOTED(HAVE_PACKED_OBJECT_VALUE, $ac_result, [Whether struct _zend_object_value is packed])
-   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support]) 
+@@ -2,6 +2,6 @@
+ dnl config.m4 for extension SPL
+   AC_DEFINE(HAVE_SPL, 1, [Whether you want SPL (Standard PHP Library) support])
 -  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
 +  PHP_NEW_EXTENSION(spl, php_spl.c spl_functions.c spl_engine.c spl_iterators.c spl_array.c spl_directory.c spl_exceptions.c spl_observer.c spl_dllist.c spl_heap.c spl_fixedarray.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
    PHP_INSTALL_HEADERS([ext/spl], [php_spl.h spl_array.h spl_directory.h spl_engine.h spl_exceptions.h spl_functions.h spl_iterators.h spl_observer.h spl_dllist.h spl_heap.h spl_fixedarray.h])
This page took 0.506832 seconds and 4 git commands to generate.