]> git.pld-linux.org Git - packages/php.git/commitdiff
fix phar manual packaging
authorElan Ruusamäe <glen@delfi.ee>
Sun, 31 Jan 2016 13:05:46 +0000 (15:05 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 31 Jan 2016 13:06:49 +0000 (15:06 +0200)
phar.1 and phar.phar.1 are links
pharXY.1 is the real man page

php.spec

index ba51100decb437bca00b1bed268c23e87f792535..ab5c5e16f06c558925915412e6669c3377f8096e 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2611,9 +2611,10 @@ cp -pf Makefile.cli Makefile
 
 # version the .phar files
 mv $RPM_BUILD_ROOT%{_bindir}/phar{,%{ver_suffix}}.phar
-mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.phar.1
+mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.1
 # make link relative
 ln -sfn phar%{ver_suffix}.phar $RPM_BUILD_ROOT%{_bindir}/phar
+ln -sfn phar%{ver_suffix}.1 $RPM_BUILD_ROOT%{_mandir}/man1/phar.1
 
 # version suffix
 v=$(echo %{version} | cut -d. -f1-2)
@@ -3404,8 +3405,9 @@ fi
 %attr(755,root,root) %{php_extensiondir}/phar.so
 %attr(755,root,root) %{_bindir}/phar
 %attr(755,root,root) %{_bindir}/phar%{ver_suffix}.phar
-%{_mandir}/man1/phar.1*
-%{_mandir}/man1/phar%{ver_suffix}.phar.1
+%{_mandir}/man1/phar.1
+%{_mandir}/man1/phar.phar.1
+%{_mandir}/man1/phar%{ver_suffix}.1*
 %endif
 
 %if %{with posix}
This page took 0.659893 seconds and 4 git commands to generate.