]> git.pld-linux.org Git - packages/php.git/commitdiff
- removed obsolete patches and BRs
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 8 May 2014 19:50:27 +0000 (21:50 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 8 May 2014 19:50:27 +0000 (21:50 +0200)
- updated system_gd bcond (imagerotate from gd 2.1+ is required now; imageantialias currently not available with system gd)

bug-52448.patch [deleted file]
mysqlnd-shared.patch [deleted file]
php-curl-limit-speed.patch [deleted file]
php-gd_imagerotate_enable.patch [deleted file]
php-krb5-ac.patch [deleted file]
php-m4-divert.patch [deleted file]
php-m4.patch [deleted file]
php-zlib.patch [deleted file]
php.spec

diff --git a/bug-52448.patch b/bug-52448.patch
deleted file mode 100644 (file)
index b15ea82..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
---- php-5.3.3/ext/curl/tests/curl_error_basic.phpt~    2009-07-03 03:09:08.000000000 +0300
-+++ php-5.3.3/ext/curl/tests/curl_error_basic.phpt     2010-07-26 21:02:34.822382923 +0300
-@@ -30,4 +30,4 @@
- ?>
- --EXPECT--
- == Testing curl_error with a fake URL ==
--Error: Couldn't resolve host 'fakeURL'
-+Error: Could not resolve host: fakeURL (Domain name not found)
diff --git a/mysqlnd-shared.patch b/mysqlnd-shared.patch
deleted file mode 100644 (file)
index 43eceb6..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- php-5.4.0alpha2/ext/mysqlnd/config9.m4~    2011-03-23 19:14:28.000000000 +0200
-+++ php-5.4.0alpha2/ext/mysqlnd/config9.m4     2011-08-07 12:45:42.205921715 +0300
-@@ -28,7 +28,7 @@
-   AC_DEFINE([MYSQLND_SSL_SUPPORTED], 1, [Enable SSL support])
-   mysqlnd_sources="$mysqlnd_base_sources $mysqlnd_ps_sources"
--  PHP_NEW_EXTENSION(mysqlnd, $mysqlnd_sources, no)
-+  PHP_NEW_EXTENSION(mysqlnd, $mysqlnd_sources, yes)
-   PHP_ADD_BUILD_DIR([ext/mysqlnd], 1)
-   PHP_INSTALL_HEADERS([ext/mysqlnd/])
- fi
---- php-5.3.2/ext/mysqlnd/php_mysqlnd.c~       2010-01-20 19:09:28.000000000 +0200
-+++ php-5.3.2/ext/mysqlnd/php_mysqlnd.c        2010-04-14 09:18:30.725599897 +0300
-@@ -273,6 +273,9 @@
- };
- /* }}} */
-+#ifdef COMPILE_DL_MYSQLND
-+ZEND_GET_MODULE(mysqlnd)
-+#endif
- /*
-  * Local variables:
diff --git a/php-curl-limit-speed.patch b/php-curl-limit-speed.patch
deleted file mode 100644 (file)
index 8348dd4..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- php-5.2.5.orig/ext/curl/interface.c        2008-03-26 17:05:19.000000000 +0100
-+++ php-5.2.5/ext/curl/interface.c     2008-03-26 17:09:05.000000000 +0100
-@@ -462,6 +462,14 @@
-       REGISTER_CURL_CONSTANT(CURLOPT_TCP_NODELAY);
- #endif
-       REGISTER_CURL_CONSTANT(CURLOPT_HTTP200ALIASES);
-+
-+/* Added constants to support limiting the transfer speed in PHP */
-+/* Fixed by Tijnema (admin@tijnema.info) */
-+#if LIBCURL_VERSION_NUM > 0x070fff /* CURLOPT_MAX_SEND_SPEED_LARGE and CURLOPT_MAX_SEND_SPEED_LARGE are available since curl 7.16.0 */
-+      REGISTER_CURL_CONSTANT(CURLOPT_MAX_SEND_SPEED_LARGE);
-+      REGISTER_CURL_CONSTANT(CURLOPT_MAX_RECV_SPEED_LARGE);
-+#endif
-+
-       REGISTER_CURL_CONSTANT(CURL_TIMECOND_IFMODSINCE);
-       REGISTER_CURL_CONSTANT(CURL_TIMECOND_IFUNMODSINCE);
-       REGISTER_CURL_CONSTANT(CURL_TIMECOND_LASTMOD);
-@@ -1288,6 +1296,12 @@
- #if LIBCURL_VERSION_NUM > 0x070b01 /* CURLOPT_TCP_NODELAY is available since curl 7.11.2 */
-               case CURLOPT_TCP_NODELAY:
- #endif
-+/* Added case options to support limiting the transfer speed in PHP */
-+/* Fixed by Tijnema (admin@tijnema.info) */
-+#if LIBCURL_VERSION_NUM > 0x070fff /* CURLOPT_MAX_SEND_SPEED_LARGE and CURLOPT_MAX_SEND_SPEED_LARGE are available since curl 7.16.0 */
-+              case CURLOPT_MAX_SEND_SPEED_LARGE:
-+              case CURLOPT_MAX_RECV_SPEED_LARGE:
-+#endif
-                       convert_to_long_ex(zvalue);
-                       error = curl_easy_setopt(ch->cp, option, Z_LVAL_PP(zvalue));
-                       break;
diff --git a/php-gd_imagerotate_enable.patch b/php-gd_imagerotate_enable.patch
deleted file mode 100644 (file)
index 6d1e74c..0000000
+++ /dev/null
@@ -1,173 +0,0 @@
-diff -ur php5.3-200812262130/ext/gd/config.m4 mod/ext/gd/config.m4
---- php5.3-200812262130/ext/gd/config.m4       2008-07-18 04:34:20.000000000 +0200
-+++ mod/ext/gd/config.m4       2008-12-27 01:12:23.000000000 +0100
-@@ -255,6 +255,7 @@
-   PHP_CHECK_LIBRARY(gd, gdFreeFontCache,        [AC_DEFINE(HAVE_GD_FREEFONTCACHE,    1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
-   PHP_CHECK_LIBRARY(gd, gdFontCacheMutexSetup,  [AC_DEFINE(HAVE_GD_FONTMUTEX,        1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
-   PHP_CHECK_LIBRARY(gd, gdNewDynamicCtxEx,      [AC_DEFINE(HAVE_GD_DYNAMIC_CTX_EX,   1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
-+  PHP_CHECK_LIBRARY(gd, gdImageRotate,          [AC_DEFINE(HAVE_GD_ROTATE,           1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
- ])
- dnl
-@@ -308,6 +309,7 @@
-   AC_DEFINE(HAVE_GD_FONTMUTEX,        1, [ ])
-   AC_DEFINE(HAVE_GD_DYNAMIC_CTX_EX,   1, [ ])
-   AC_DEFINE(HAVE_GD_GIF_CTX,          1, [ ])
-+  AC_DEFINE(HAVE_GD_ROTATE,           1, [ ])
- dnl Make sure the libgd/ is first in the include path
-   GDLIB_CFLAGS="-DHAVE_LIBPNG"
-diff -ur php5.3-200812262130/ext/gd/gd.c mod/ext/gd/gd.c
---- php5.3-200812262130/ext/gd/gd.c    2008-12-12 14:35:20.000000000 +0100
-+++ mod/ext/gd/gd.c    2008-12-27 01:18:43.000000000 +0100
-@@ -296,7 +296,7 @@
- ZEND_END_ARG_INFO()
- #endif
--#ifdef HAVE_GD_BUNDLED
-+#ifdef HAVE_GD_ROTATE
- ZEND_BEGIN_ARG_INFO_EX(arginfo_imagerotate, 0, 0, 3)
-       ZEND_ARG_INFO(0, im)
-       ZEND_ARG_INFO(0, angle)
-@@ -927,9 +927,12 @@
-       PHP_FE(imagegrabscreen,                                                 arginfo_imagegrabscreen)
- #endif
-+#ifdef HAVE_GD_ROTATE
-+      PHP_FE(imagerotate,                                                     arginfo_imagerotate)
-+#endif
-+
- #ifdef HAVE_GD_BUNDLED
--      PHP_FE(imagerotate,                                                     arginfo_imagerotate)
--      PHP_FE(imageantialias,                                                  arginfo_imageantialias)
-+      PHP_FE(imageantialias,                                                  arginfo_imageantialias)
- #endif
- #if HAVE_GD_IMAGESETTILE
-@@ -1079,7 +1082,7 @@
-       PHP_INI_ENTRY("gd.jpeg_ignore_warning", "0", PHP_INI_ALL, NULL)
- PHP_INI_END()
- /* }}} */
--      
-+
- /* {{{ php_free_gd_image
-  */
- static void php_free_gd_image(zend_rsrc_list_entry *rsrc TSRMLS_DC)
-@@ -1140,7 +1143,7 @@
- #endif
-       REGISTER_INI_ENTRIES();
--      
-+
-       REGISTER_LONG_CONSTANT("IMG_GIF", 1, CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMG_JPG", 2, CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMG_JPEG", 2, CONST_CS | CONST_PERSISTENT);
-@@ -1168,11 +1171,14 @@
- #ifdef GD2_FMT_COMPRESSED
-       REGISTER_LONG_CONSTANT("IMG_GD2_COMPRESSED", GD2_FMT_COMPRESSED, CONST_CS | CONST_PERSISTENT);
- #endif
--#if HAVE_GD_BUNDLED
-+#if HAVE_GD_ROTATE
-       REGISTER_LONG_CONSTANT("IMG_EFFECT_REPLACE", gdEffectReplace, CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMG_EFFECT_ALPHABLEND", gdEffectAlphaBlend, CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMG_EFFECT_NORMAL", gdEffectNormal, CONST_CS | CONST_PERSISTENT);
-       REGISTER_LONG_CONSTANT("IMG_EFFECT_OVERLAY", gdEffectOverlay, CONST_CS | CONST_PERSISTENT);
-+#endif
-+
-+#if HAVE_GD_BUNDLED
-       REGISTER_LONG_CONSTANT("GD_BUNDLED", 1, CONST_CS | CONST_PERSISTENT);
-       /* Section Filters */
-@@ -1760,7 +1766,7 @@
-       long cx, cy, w, h, ST, E, col, style;
-       gdImagePtr im;
-       int e, st;
--      
-+
-       if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rllllllll", &IM, &cx, &cy, &w, &h, &ST, &E, &col, &style) == FAILURE) {
-               return;
-       }
-@@ -2008,7 +2014,7 @@
-       if ( handle == 0 ) {
-               goto clean;
-       }
--      pPrintWindow = (tPrintWindow) GetProcAddress(handle, "PrintWindow");  
-+      pPrintWindow = (tPrintWindow) GetProcAddress(handle, "PrintWindow");
-       if ( pPrintWindow )  {
-               pPrintWindow(window, memDC, (UINT) client_area);
-@@ -2105,7 +2111,7 @@
- /* }}} */
- #endif /* PHP_WIN32 */
--#ifdef HAVE_GD_BUNDLED
-+#ifdef HAVE_GD_ROTATE
- /* {{{ proto resource imagerotate(resource src_im, float angle, int bgdcolor [, int ignoretransparent])
-    Rotate an image using a custom angle */
- PHP_FUNCTION(imagerotate)
-@@ -3362,7 +3368,7 @@
- {
-       zval *IM;
-       gdImagePtr im;
--      
-+
-       if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "r", &IM) == FAILURE) {
-               return;
-       }
-@@ -3946,7 +3952,7 @@
-                       if (zend_hash_get_current_data_ex(HASH_OF(EXT), (void **) &item, &pos) == FAILURE) {
-                               continue;
-                       }
--              
-+
-                       if (strcmp("linespacing", key) == 0) {
-                               convert_to_double_ex(item);
-                               strex.flags |= gdFTEX_LINESPACE;
-@@ -3972,7 +3978,7 @@
- #endif
-       PHP_GD_CHECK_OPEN_BASEDIR((char *)fontname, "Invalid font filename");
--      
-+
- #ifdef USE_GD_IMGSTRTTF
- # if HAVE_GD_STRINGFTEX
-       if (extended) {
-@@ -4373,11 +4379,11 @@
-       if (argc != 3 && argc != 6) {
-               ZEND_WRONG_PARAM_COUNT();
-       }
--      
-+
-       if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "srl|lld", &str, &str_len, &fnt, &sz, &sp, &wd, &angle) == FAILURE) {
-               return;
-       }
--      
-+
-       if (argc == 6) {
-               space = sp;
-               add_width = wd;
-@@ -4562,7 +4568,7 @@
- #ifdef HAVE_GD_JPG
-     long ignore_warning;
- #endif
--      
-+
-       if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "sslll", &f_org, &f_org_len, &f_dest, &f_dest_len, &height, &width, &threshold) == FAILURE) {
-               return;
-       }
-diff -ur php5.3-200812262130/ext/gd/php_gd.h mod/ext/gd/php_gd.h
---- php5.3-200812262130/ext/gd/php_gd.h        2008-07-18 04:34:20.000000000 +0200
-+++ mod/ext/gd/php_gd.h        2008-12-27 01:20:04.000000000 +0100
-@@ -119,8 +119,11 @@
- PHP_FUNCTION(imagegrabscreen);
- #endif
--#ifdef HAVE_GD_BUNDLED
-+#ifdef HAVE_GD_ROTATE
- PHP_FUNCTION(imagerotate);
-+#endif
-+
-+#ifdef HAVE_GD_BUNDLED
- PHP_FUNCTION(imageantialias);
- #endif
diff --git a/php-krb5-ac.patch b/php-krb5-ac.patch
deleted file mode 100644 (file)
index c7bddd1..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- php-5.3.3/acinclude.m4.orig        2010-10-19 21:38:42.000000000 +0200
-+++ php-5.3.3/acinclude.m4     2010-10-19 22:53:11.792893220 +0200
-@@ -2252,7 +2252,7 @@
-     KERBEROS_LIBS=`$KRB5_CONFIG --libs gssapi`
-     KERBEROS_CFLAGS=`$KRB5_CONFIG --cflags gssapi`
--    if test -n "$KERBEROS_LIBS" && test -n "$KERBEROS_CFLAGS"; then
-+    if test -n "$KERBEROS_LIBS" || test -n "$KERBEROS_CFLAGS"; then
-       found_kerberos=yes
-       PHP_EVAL_LIBLINE($KERBEROS_LIBS, $1)
-       PHP_EVAL_INCLINE($KERBEROS_CFLAGS)
diff --git a/php-m4-divert.patch b/php-m4-divert.patch
deleted file mode 100644 (file)
index f4e5bb5..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-diff -ur php-5.3.0.org/configure.in php-5.3.0/configure.in
---- php-5.3.0.org/configure.in 2009-06-26 17:44:18.000000000 +0200
-+++ php-5.3.0/configure.in     2009-08-18 12:45:19.126841759 +0200
-@@ -1,7 +1,7 @@
- ## $Id$ -*- autoconf -*-
- dnl ## Process this file with autoconf to produce a configure script.
--divert(1)
-+divert(1001)
- dnl ## Diversion 1 is the autoconf + automake setup phase. We also
- dnl ## set the PHP version, deal with platform-specific compile
-@@ -308,7 +308,7 @@
- sinclude(TSRM/tsrm.m4)
--divert(2)
-+divert(1002)
- dnl ## Diversion 2 is where we set PHP-specific options and come up
- dnl ## with reasonable default values for them. We check for pthreads here
-@@ -347,7 +347,7 @@
-   PTHREADS_FLAGS
- fi
--divert(3)
-+divert(1003)
- dnl ## In diversion 3 we check for compile-time options to the PHP
- dnl ## core and how to deal with different system dependencies. 
-@@ -702,7 +702,7 @@
-   PHP_CRYPT_R_STYLE
- fi
--divert(4)
-+divert(1004)
- dnl ## In diversion 4 we check user-configurable general settings.
-@@ -943,7 +943,7 @@
-   AC_MSG_RESULT([using system default])
- fi
--divert(5)
-+divert(1005)
- dnl ## In diversion 5 we check which extensions should be compiled.
- dnl ## All of these are normally in the extension directories.
-diff -ur php-5.3.0.org/ext/standard/config.m4 php-5.3.0/ext/standard/config.m4
---- php-5.3.0.org/ext/standard/config.m4       2009-01-12 00:37:16.000000000 +0100
-+++ php-5.3.0/ext/standard/config.m4   2009-08-18 12:45:19.130174674 +0200
-@@ -1,6 +1,6 @@
- dnl $Id$ -*- autoconf -*-
--divert(3)dnl
-+divert(1003)dnl
- dnl
- dnl Check if flush should be called explicitly after buffered io
-@@ -220,7 +220,7 @@
- AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
- AC_FUNC_FNMATCH       
--divert(5)dnl
-+divert(1005)dnl
- dnl
- dnl Check if there is a support means of creating a new process
-diff -ur php-5.3.0.org/scripts/phpize.m4 php-5.3.0/scripts/phpize.m4
---- php-5.3.0.org/scripts/phpize.m4    2009-06-02 21:54:03.000000000 +0200
-+++ php-5.3.0/scripts/phpize.m4        2009-08-18 12:45:19.126841759 +0200
-@@ -1,6 +1,6 @@
- dnl This file becomes configure.in for self-contained extensions.
--divert(1)
-+divert(1001)
- AC_PREREQ(2.13)
- AC_INIT(config.m4)
diff --git a/php-m4.patch b/php-m4.patch
deleted file mode 100644 (file)
index e7981a4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- php-5.3.7/build/buildcheck.sh~     2011-05-18 21:55:34.000000000 +0200
-+++ php-5.3.7/build/buildcheck.sh      2011-08-20 18:28:38.223862911 +0200
-@@ -51,7 +51,7 @@
-   echo "           On Debian/Ubuntu both autoconf2.13 and autoconf2.59 packages exist."
-   echo "           Install autoconf2.13 and set the PHP_AUTOCONF env var to "
-   echo "           autoconf2.13 and try again."
--  exit 1
-+  echo "           CONTINUING ANYWAY."
- else
-   echo "buildconf: autoconf version $ac_version (ok)"
- fi
diff --git a/php-zlib.patch b/php-zlib.patch
deleted file mode 100644 (file)
index 1ee4b30..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -burN php-5.0.0b3/ext/zlib/zlib.c php-5.0.0b3-zlib/ext/zlib/zlib.c
---- php-5.0.0b3/ext/zlib/zlib.c        2003-09-26 10:09:53.000000000 +0200
-+++ php-5.0.0b3-zlib/ext/zlib/zlib.c   2003-12-27 00:40:53.000000000 +0100
-@@ -979,6 +979,11 @@
-       if (ZLIBG(output_handler) && strlen(ZLIBG(output_handler))) {
-               php_start_ob_buffer_named(ZLIBG(output_handler), 0, 1 TSRMLS_CC);
-+              if (sapi_add_header("Content-Encoding: gzip", sizeof("Content-Encoding: gzip") - 1        , 1)!=FAILURE) {
-+                      if (sapi_add_header("Vary: Accept-Encoding", sizeof("Vary: Accept-Encoding") - 1, 1)==FAILURE) {
-+                              SG(sapi_headers).send_default_content_type = 0;
-+                      }
-+              }
-       }
-       return SUCCESS;
- }
index f38068b0e8cb02093354ad3c69cdfab3541eac67..2d8d9423246d20a50173c7df1e49b5829e5be23c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,13 +2,11 @@
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
 # - build with system libgd 2.1, see 73c5128
 # TODO 5.4:
-# - do not remove PatchX: definitions until merged to HEAD, needed for tracking their state
 # - check php-sapi-ini-file.patch for safe mode removal
 # - update imap annotations patch (needs api porting)
 # - update imap myrights patch (needs api porting)
 # --with-libmbfl=DIR      MBSTRING: Use external libmbfl.  DIR is the libmbfl base install directory BUNDLED
 # --with-onig=DIR         MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
-# - uses libvpx for webp support, should use libwebp-devel instead?
 # NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
@@ -45,7 +43,7 @@
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_without instantclient   # build Oracle oci8 extension module against oracle-instantclient package
-%bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
+%bcond_with    system_gd       # with system gd (imageantialias function is missing then)
 %bcond_with    system_libzip   # with system libzip (reported broken currently)
 %bcond_without default_php     # use this PHP as default PHP in distro
 %bcond_without curl            # without CURL extension module
@@ -172,10 +170,8 @@ Patch11:   embed.patch
 Patch12:       http://ilia.ws/patch/type_hint_53_v2.txt
 %endif
 Patch14:       %{orgname}-no_pear_install.patch
-#Patch15:      %{orgname}-zlib.patch # no longer needed?
 Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
-Patch19:       %{orgname}-gd_imagerotate_enable.patch
 Patch20:       %{orgname}-uint32_t.patch
 Patch21:       %{orgname}-dba-link.patch
 Patch22:       %{orgname}-both-apxs.patch
@@ -186,7 +182,6 @@ Patch26:    %{orgname}-pear.patch
 Patch27:       %{orgname}-config-dir.patch
 Patch29:       %{orgname}-fcgi-graceful.patch
 Patch31:       %{orgname}-fcgi-error_log-no-newlines.patch
-#Patch32:      %{orgname}-curl-limit-speed.patch # applied upstream
 Patch34:       %{orgname}-libtool.patch
 Patch35:       %{orgname}-tds.patch
 Patch36:       %{orgname}-mysql-charsetphpini.patch
@@ -200,20 +195,15 @@ Patch44:  %{orgname}-include_path.patch
 Patch45:       %{orgname}-imap-annotations.patch
 Patch46:       %{orgname}-imap-myrights.patch
 Patch47:       suhosin.patch
-#Patch49:      %{orgname}-m4-divert.patch # no longer needed, upstream supports new ac
 Patch50:       extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
 Patch52:       pcre-shared.patch
 Patch53:       fix-test-run.patch
-#Patch54:      mysqlnd-shared.patch # shared build supported upstream
 Patch55:       bug-52078-fileinode.patch
-#Patch57:      bug-52448.patch # outdated
 Patch59:       %{orgname}-systzdata.patch
 Patch60:       %{orgname}-oracle-instantclient.patch
-#Patch61:      %{orgname}-krb5-ac.patch # not needed on 5.4 anymore
 Patch62:       mcrypt-libs.patch
 Patch63:       %{orgname}-mysql-nowarning.patch
-#Patch64:      %{orgname}-m4.patch # not needed on 5.4 branch
 Patch65:       system-libzip.patch
 Patch66:       php-db.patch
 Patch67:       mysql-lib-ver-mismatch.patch
@@ -231,7 +221,6 @@ BuildRequires:      cyrus-sasl-devel
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
-#BuildRequires:        fcgi-devel
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10.1-2}
 %{!?with_mysqlnd:BuildRequires:        mysql-devel}
@@ -252,7 +241,6 @@ BuildRequires:      libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
-#BuildRequires:        libtiff-devel
 %{?with_webp:BuildRequires:    libvpx-devel}
 BuildRequires: tokyocabinet-devel
 %if "%{pld_release}" != "ac"
@@ -260,7 +248,6 @@ BuildRequires:      libtool >= 2:2.2
 %else
 BuildRequires: libtool >= 1.4.3
 %endif
-#BuildRequires:        libwrap-devel
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
@@ -300,9 +287,6 @@ BuildRequires:      apache-devel >= 2.0.52-2
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.0.0
 %endif
-%if %{with fpm}
-#BuildRequires:        judy-devel
-%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/%{name}
@@ -856,9 +840,8 @@ Group:              Libraries
 URL:           http://www.php.net/manual/en/book.image.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 %if %{with system_gd}
-Requires:      gd >= 2.0.28-4
+Requires:      gd >= 2.1
 Requires:      gd(gif)
-Requires:      gd(imagerotate) = 5.2.0
 %endif
 Provides:      php(gd)
 
@@ -1859,8 +1842,8 @@ URL:              http://www.php.net/manual/en/book.xsl.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-dom = %{epoch}:%{version}-%{release}
 Requires:      libxslt >= 1.0.18
-# actually not true, functionality is similar, but API differs
 Provides:      php(xsl)
+# actually not true, functionality is similar, but API differs
 Obsoletes:     php-xslt <= 3:4.3.8-1
 
 %description xsl
@@ -1921,9 +1904,6 @@ cp -p php.ini-production php.ini
 %patch14 -p1
 %patch17 -p1
 %patch18 -p1
-%if %{with system_gd}
-%patch19 -p1
-%endif
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
This page took 0.073578 seconds and 4 git commands to generate.