]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- removed obsolete patches and BRs
[packages/php.git] / php.spec
index d518e92db2de84d745a22df6471c1e22d60f7377..2d8d9423246d20a50173c7df1e49b5829e5be23c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,12 +1,12 @@
+# TODO 5.5:
+# - enable --with-fpm-systemd, but ensure it checks for sd_booted()
+# - build with system libgd 2.1, see 73c5128
 # TODO 5.4:
-# - do not remove PatchX: definitions until merged to HEAD, needed for tracking their state
 # - check php-sapi-ini-file.patch for safe mode removal
-# - enable litespeed (needs api porting)
 # - update imap annotations patch (needs api porting)
 # - update imap myrights patch (needs api porting)
 # --with-libmbfl=DIR      MBSTRING: Use external libmbfl.  DIR is the libmbfl base install directory BUNDLED
 # --with-onig=DIR         MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
-# - uses libvpx for webp support, should use libwebp-devel instead?
 # NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
 # Conditional build:
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
-%bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
-%bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
+%bcond_without instantclient   # build Oracle oci8 extension module against oracle-instantclient package
+%bcond_with    system_gd       # with system gd (imageantialias function is missing then)
 %bcond_with    system_libzip   # with system libzip (reported broken currently)
+%bcond_without default_php     # use this PHP as default PHP in distro
 %bcond_without curl            # without CURL extension module
 %bcond_without enchant         # without Enchant extension module
 %bcond_without filter          # without filter extension module
@@ -52,7 +53,7 @@
 %bcond_without interbase       # without InterBase extension module
 %bcond_without intl            # without Intl extension module
 %bcond_without kerberos5       # without Kerberos5 support
-%bcond_with    litespeed       # build litespeed module
+%bcond_without litespeed       # build litespeed module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_without mm              # without mm support for session storage
@@ -61,6 +62,7 @@
 %bcond_with    mysqlnd         # with mysqlnd support in mysql related extensions
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
 %bcond_without odbc            # without ODBC extension module
+%bcond_without opcache         # without Enable Zend OPcache extension support
 %bcond_without openssl         # without OpenSSL support and OpenSSL extension (module)
 %bcond_without pcre            # without PCRE extension module
 %bcond_without pdo_sqlite      # without PDO SQLite extension module
@@ -81,7 +83,7 @@
 %bcond_with    zts             # Zend Thread Safety
 %bcond_without cgi             # disable CGI/FCGI SAPI
 %bcond_without fpm             # disable FPM
-%bcond_with    embed           # disable Embedded API
+%bcond_without embed           # disable Embedded API
 %bcond_without suhosin         # with suhosin patch
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    gcov            # Enable Code coverage reporting
@@ -89,7 +91,6 @@
 
 %define apxs1          /usr/sbin/apxs1
 %define        apxs2           /usr/sbin/apxs
-%define        litespeed_version       5.5
 
 # disable all sapis
 %if %{with gcov}
@@ -125,10 +126,10 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
+%define                rel     1
 %define                orgname php
-%define                php_suffix 54
-
-%define                rel     0.16
+%define                ver_suffix 55
+%define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -136,13 +137,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.4.6
+Version:       5.5.12
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
-Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: c9aa0f4996d1b91ee9e45afcfaeb5d2e
+Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
+# Source0-md5: 3fb091987063135fd86b3b5ba5010479
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -154,9 +155,6 @@ Source11:   %{orgname}-fpm.logrotate
 Source12:      %{orgname}-branch.sh
 Source13:      dep-tests.sh
 Source14:      skip-tests.sh
-# Source15Download: http://litespeedtech.com/lsapi-downloads.html
-Source15:      http://litespeedtech.com/packages/lsapi/%{orgname}-litespeed-%{litespeed_version}.tgz
-# Source15-md5:        9d58485d5fd6b5f5fefcec41b9ce283e
 Patch0:                %{orgname}-shared.patch
 Patch1:                %{orgname}-pldlogo.patch
 Patch2:                %{orgname}-mail.patch
@@ -165,18 +163,15 @@ Patch4:           %{orgname}-libpq_fs_h_path.patch
 Patch5:                %{orgname}-filter-shared.patch
 Patch6:                %{orgname}-build_modules.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch8:                %{orgname}-config-file-scan-dir.patch
-Patch9:                %{orgname}-sh.patch
+
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 %if %{with type_hints}
 Patch12:       http://ilia.ws/patch/type_hint_53_v2.txt
 %endif
 Patch14:       %{orgname}-no_pear_install.patch
-#Patch15:      %{orgname}-zlib.patch # no longer needed?
 Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
-Patch19:       %{orgname}-gd_imagerotate_enable.patch
 Patch20:       %{orgname}-uint32_t.patch
 Patch21:       %{orgname}-dba-link.patch
 Patch22:       %{orgname}-both-apxs.patch
@@ -187,7 +182,6 @@ Patch26:    %{orgname}-pear.patch
 Patch27:       %{orgname}-config-dir.patch
 Patch29:       %{orgname}-fcgi-graceful.patch
 Patch31:       %{orgname}-fcgi-error_log-no-newlines.patch
-#Patch32:      %{orgname}-curl-limit-speed.patch # applied upstream
 Patch34:       %{orgname}-libtool.patch
 Patch35:       %{orgname}-tds.patch
 Patch36:       %{orgname}-mysql-charsetphpini.patch
@@ -201,21 +195,20 @@ Patch44:  %{orgname}-include_path.patch
 Patch45:       %{orgname}-imap-annotations.patch
 Patch46:       %{orgname}-imap-myrights.patch
 Patch47:       suhosin.patch
-#Patch49:      %{orgname}-m4-divert.patch # no longer needed, upstream supports new ac
 Patch50:       extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
 Patch52:       pcre-shared.patch
 Patch53:       fix-test-run.patch
-#Patch54:      mysqlnd-shared.patch # shared build supported upstream
 Patch55:       bug-52078-fileinode.patch
-#Patch57:      bug-52448.patch # outdated
 Patch59:       %{orgname}-systzdata.patch
 Patch60:       %{orgname}-oracle-instantclient.patch
-#Patch61:      %{orgname}-krb5-ac.patch # not needed on 5.4 anymore
 Patch62:       mcrypt-libs.patch
 Patch63:       %{orgname}-mysql-nowarning.patch
-#Patch64:      %{orgname}-m4.patch # not needed on 5.4 branch
 Patch65:       system-libzip.patch
+Patch66:       php-db.patch
+Patch67:       mysql-lib-ver-mismatch.patch
+
+Patch69:       fpm-conf-split.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -228,8 +221,6 @@ BuildRequires:      cyrus-sasl-devel
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
-#BuildRequires:        fcgi-devel
-#BuildRequires:        flex
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10.1-2}
 %{!?with_mysqlnd:BuildRequires:        mysql-devel}
@@ -238,20 +229,18 @@ BuildRequires:    sed >= 4.0
 %if %{with mssql} || %{with sybase_ct}
 BuildRequires: freetds-devel >= 0.82
 %endif
-BuildRequires: freetype-devel >= 2.0
+BuildRequires: freetype-devel >= 2.5.1
 %if %{with system_gd}
-BuildRequires: gd-devel >= 2.0.28-4
-BuildRequires: gd-devel(imagerotate) = 5.2.0
+BuildRequires: gd-devel >= 2.1
 %endif
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel
 %{?with_imap:BuildRequires:    imap-devel >= 1:2007e-2}
-%{?with_intl:BuildRequires:    libicu-devel}
+%{?with_intl:BuildRequires:    libicu-devel >= 4.4}
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
-#BuildRequires:        libtiff-devel
 %{?with_webp:BuildRequires:    libvpx-devel}
 BuildRequires: tokyocabinet-devel
 %if "%{pld_release}" != "ac"
@@ -259,7 +248,6 @@ BuildRequires:      libtool >= 2:2.2
 %else
 BuildRequires: libtool >= 1.4.3
 %endif
-#BuildRequires:        libwrap-devel
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
@@ -270,7 +258,7 @@ BuildRequires:      openssl-devel >= 0.9.7d
 %{?with_gcov:BuildRequires:    lcov}
 %{?with_snmp:%{?with_tests:BuildRequires:      mibs-net-snmp}}
 %{?with_snmp:BuildRequires:    net-snmp-devel >= 5.0.7}
-%{?with_instantclient:BuildRequires:   oracle-instantclient-devel}
+%{?with_oci8:%{?with_instantclient:BuildRequires:      oracle-instantclient-devel}}
 BuildRequires: pam-devel
 %{?with_pcre:BuildRequires:    pcre-devel >= 8.10}
 BuildRequires: pkgconfig
@@ -281,6 +269,8 @@ BuildRequires:      readline-devel
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpm-build >= 4.4.0
 BuildRequires: rpmbuild(macros) >= 1.566
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 %if %{with sqlite3} || %{with pdo_sqlite}
 BuildRequires: sqlite3-devel >= 3.3.9
 %endif
@@ -297,9 +287,6 @@ BuildRequires:      apache-devel >= 2.0.52-2
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.0.0
 %endif
-%if %{with fpm}
-#BuildRequires:        judy-devel
-%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/%{name}
@@ -307,9 +294,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20100412
-%define                zend_module_api         20100525
-%define                zend_extension_api      220100525
+%define                php_api_version         20121113
+%define                zend_module_api         20121212
+%define                zend_extension_api      220121212
 
 # Extension versions
 %define                bz2ver          1.0
@@ -318,8 +305,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.2.1
-%define                pharver         2.0.1
-%define                sqlite3ver      0.7
+%define                opcachever      7.0.4-dev
+%define                pharver         2.0.2
+%define                sqlite3ver      0.7-dev
 %define                zipver          1.11.0
 
 %define                zend_zts                %{!?with_zts:0}%{?with_zts:1}
@@ -426,6 +414,7 @@ Summary:    PHP for litespeed HTTP server
 Summary(pl.UTF-8):     PHP dla serwera HTTP litespeed
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(litespeed)
 Provides:      webserver(php) = %{version}
 
 %description litespeed
@@ -442,8 +431,11 @@ Requires:  %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      %{name}-fcgi = %{epoch}:%{version}-%{release}
 Provides:      php(cgi)
 Provides:      php(fcgi)
-Provides:      webserver(php)
+Provides:      webserver(php) = %{version}
 Obsoletes:     php-fcgi < 4:5.3.0
+%if "%{pld_release}" != "ac"
+Conflicts:     logrotate < 3.8.0
+%endif
 
 %description cgi
 PHP as CGI or FastCGI program.
@@ -501,6 +493,7 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      rc-scripts
+Provides:      php(fpm)
 Provides:      user(http)
 Provides:      webserver(php) = %{version}
 
@@ -519,7 +512,7 @@ Group:              Libraries
 Requires(post):        sed >= 4.0
 # because of dlclose() bugs in glibc <= 2.3.4 causing SEGVs on exit
 Requires:      glibc >= 6:2.3.5
-Requires:      php-dirs
+Requires:      php-dirs >= 1.4
 Requires:      rpm-whiteout >= 1.28
 Requires:      tzdata
 Provides:      %{name}(debug) = %{php_debug}
@@ -527,13 +520,14 @@ Provides: %{name}(modules_api) = %{php_api_version}
 Provides:      %{name}(thread-safety) = %{zend_zts}
 Provides:      %{name}(zend_extension_api) = %{zend_extension_api}
 Provides:      %{name}(zend_module_api) = %{zend_module_api}
+Provides:      %{name}-core
 Provides:      %{name}-date
 Provides:      %{name}-ereg
 Provides:      %{name}-reflection
 Provides:      %{name}-standard
+Provides:      php(core) = %{version}
 Provides:      php(date)
 Provides:      php(ereg)
-Provides:      php(hash)
 Provides:      php(libxml)
 Provides:      php(reflection)
 Provides:      php(standard)
@@ -541,6 +535,7 @@ Provides:   php(standard)
 %{?with_pcre:%requires_ge_to   pcre pcre-devel}
 Obsoletes:     php-pecl-domxml
 Conflicts:     php4-common < 3:4.4.4-8
+Conflicts:     php55-common < 4:5.5.10-4
 Conflicts:     rpm < 4.4.2-0.2
 
 %description common
@@ -578,6 +573,8 @@ Obsoletes:  php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
+Obsoletes:     php53-devel
+Obsoletes:     php54-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -843,9 +840,8 @@ Group:              Libraries
 URL:           http://www.php.net/manual/en/book.image.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 %if %{with system_gd}
-Requires:      gd >= 2.0.28-4
+Requires:      gd >= 2.1
 Requires:      gd(gif)
-Requires:      gd(imagerotate) = 5.2.0
 %endif
 Provides:      php(gd)
 
@@ -1181,6 +1177,30 @@ Moduł PHP ze wsparciem dla ODBC.
 %description odbc -l pt_BR.UTF-8
 Um módulo para aplicações PHP que usam ODBC.
 
+%package opcache
+Summary:       Zend Optimizer+ - PHP code optimizer
+Summary(pl.UTF-8):     Zend Optimizer+ - optymalizator kodu PHP
+Group:         Libraries
+URL:           https://wiki.php.net/rfc/optimizerplus
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(opcache) = %{opcachever}
+
+%description opcache
+The Zend OPcache provides faster PHP execution through opcode caching
+and optimization. It improves PHP performance by storing precompiled
+script bytecode in the shared memory. This eliminates the stages of
+reading code from the disk and compiling it on future access. In
+addition, it applies a few bytecode optimization patterns that make
+code execution faster.
+
+%description opcache -l pl.UTF-8
+Zend OPcache zapewnia szybsze wykonywanie kodu PHP dzięki buforowaniu
+i optymalizacji na poziomie opcode'ów. Poprawia wydajność PHP
+przechowując prekompilowany bajtkod skryptu w pamięci współdzielonej.
+Eliminuje etapy odczytu kodu z dysku i kompilacji przy późniejszym
+dostępie. Ponadto wykonuje kilka wzorców optymalizacji bajtkodu,
+czyniąc wykonywanie kodu szybszym.
+
 %package openssl
 Summary:       OpenSSL extension module for PHP
 Summary(pl.UTF-8):     Moduł OpenSSL dla PHP
@@ -1397,11 +1417,12 @@ Group:          Libraries
 URL:           http://www.php.net/manual/en/book.phar.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
+Suggests:      %{name}-cli
 # zlib is required by phar program, but as phar cli is optional should the dep be too
 Suggests:      %{name}-zlib
-Suggests:      php-program
 Provides:      php(phar) = %{pharver}
 Obsoletes:     php-pecl-phar < %{pharver}
+Conflicts:     php-ioncube < 4.0.9
 
 %description phar
 This is a dynamic shared object (DSO) for PHP that will add phar
@@ -1481,6 +1502,7 @@ Group:            Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
 Suggests:      %{name}-hash = %{epoch}:%{version}-%{release}
+Suggests:      tmpwatch
 Provides:      php(session)
 
 %description session
@@ -1820,8 +1842,8 @@ URL:              http://www.php.net/manual/en/book.xsl.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-dom = %{epoch}:%{version}-%{release}
 Requires:      libxslt >= 1.0.18
-# actually not true, functionality is similar, but API differs
 Provides:      php(xsl)
+# actually not true, functionality is similar, but API differs
 Obsoletes:     php-xslt <= 3:4.3.8-1
 
 %description xsl
@@ -1872,9 +1894,8 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch8 -p1
 %patch7 -p1
-%patch9 -p1
+
 cp -p php.ini-production php.ini
 %patch10 -p1
 %if %{with type_hints}
@@ -1883,9 +1904,6 @@ cp -p php.ini-production php.ini
 %patch14 -p1
 %patch17 -p1
 %patch18 -p1
-%if %{with system_gd}
-%patch19 -p1
-%endif
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
@@ -1926,8 +1944,10 @@ cp -p php.ini-production php.ini
 %patch62 -p1
 %patch63 -p1
 %{?with_system_libzip:%patch65 -p1}
-%{__rm} -r sapi/litespeed
-gzip -dc %{SOURCE15} | tar xf - -C sapi/
+%patch66 -p1
+%patch67 -p1
+
+%patch69 -p1
 
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -1952,6 +1972,7 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 #%{__rm} -r ext/soap/interop
 %{__rm} -r ext/xmlrpc/libxmlrpc
 #%{__rm} -r ext/zip/lib
+%{__rm} ext/date/lib/timezonedb.h
 
 cp -pf Zend/LICENSE{,.Zend}
 install -p %{SOURCE13} dep-tests.sh
@@ -1963,6 +1984,21 @@ sed -i -e 's#-fvisibility=hidden##g' configure*
 # says just "Terminated" twice and fails
 mv sapi/cli/tests/022.phpt{,.broken}
 
+# really dumb test, executable binary name is .libs/ something when building
+# https://bugs.php.net/bug.php?id=54514
+mv tests/basic/bug54514.phpt{,.disable}
+
+# breaks whole testsuite unexpectedly:
+# Fatal error: Call to undefined function gzencode() in run-tests.php on line 1714
+# probably broken as zlib is built as shared
+mv ext/soap/tests/server019.phpt{,disable}
+# Fatal error: Call to undefined function gzcompress() in run-tests.php on line 1728
+mv ext/soap/tests/server020.phpt{,disable}
+
+# runs out of memory and kills carme vserver
+# PASS Bug #39438 (Fatal error: Out of memory) [Zend/tests/bug39438.phpt]
+mv Zend/tests/bug39438.phpt{,.disable}
+
 # php-5.3.3/ext/standard/tests/file/statpage.phpt
 %{__rm} ext/standard/tests/file/statpage.phpt
 
@@ -1971,7 +2007,24 @@ mv sapi/cli/tests/022.phpt{,.broken}
 # probably pointless.
 %{__rm} ext/standard/tests/file/disk_free_space_basic.phpt
 
-#sh -xe %{_sourcedir}/skip-tests.sh
+%ifarch %{x8664}
+# all pdo_sqlite, sqlite3 tests die with Aborted on carme
+%{__rm} -r ext/pdo_sqlite/tests
+%{__rm} -r ext/sqlite3/tests
+%endif
+
+# skip XFAILs
+# no point testing stuff that is knowingly broken
+find -name '*.phpt' | xargs grep XFAIL -l | xargs rm -v
+
+env \
+%ifarch %{ix86}
+ix86= x8664=:
+%endif
+%ifarch %{x8664}
+ix86=: x8664= \
+%endif
+       sh -xe %{_sourcedir}/skip-tests.sh
 
 %build
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
@@ -2023,6 +2076,12 @@ if test "$ver" != "%{jsonver}"; then
        : Update the jsonver macro and rebuild.
        exit 1
 fi
+ver=$(sed -n '/#define PHP_ZENDOPCACHE_VERSION /{s/.* "//;s/".*$//;p}' ext/opcache/ZendAccelerator.h)
+if test "$ver" != "%{opcachever}"; then
+       : Error: Upstream Zend Opcache version is now ${ver}, expecting %{opcachever}.
+       : Update the opcachever macro and rebuild.
+       exit 1
+fi
 ver=$(sed -rne 's,.*<version>(.+)</version>,\1,p' ext/bz2/package.xml)
 if test "$ver" != "%{bz2ver}"; then
        : Error: Upstream BZIP2 version is now ${ver}, expecting %{bz2ver}.
@@ -2098,21 +2157,21 @@ for sapi in $sapis; do
                sapi_args='--disable-cgi %{?with_gcov:--enable-gcov}'
        ;;
        fpm)
-               sapi_args='--disable-cli --enable-fpm'
+               sapi_args='--disable-cli --disable-cgi --enable-fpm'
                ;;
        embed)
-               sapi_args='--disable-cli --enable-embed'
+               sapi_args='--disable-cli --disable-cgi --enable-embed'
                ;;
        apxs1)
                ver=$(rpm -q --qf '%{V}' apache1-devel)
-               sapi_args="--disable-cli --with-apxs=%{apxs1} --with-apache-version=$ver"
+               sapi_args="--disable-cli --disable-cgi --with-apxs=%{apxs1} --with-apache-version=$ver"
        ;;
        apxs2)
                ver=$(rpm -q --qf '%{V}' apache-devel)
-               sapi_args="--disable-cli --with-apxs2=%{apxs2} --with-apache-version=$ver"
+               sapi_args="--disable-cli --disable-cgi --with-apxs2=%{apxs2} --with-apache-version=$ver"
        ;;
        litespeed)
-               sapi_args='--with-litespeed'
+               sapi_args='--disable-cli --disable-cgi --with-litespeed '
        ;;
        esac
 
@@ -2200,6 +2259,7 @@ for sapi in $sapis; do
        --with-mysql=shared,%{!?with_mysqlnd:/usr}%{?with_mysqlnd:mysqlnd} \
        %{?with_mysqli:--with-mysqli=shared,%{!?with_mysqlnd:/usr/bin/mysql_config}%{?with_mysqlnd:mysqlnd}} \
        %{?with_oci8:--with-oci8=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
+       %{?with_opcache:--enable-opcache=shared} \
        %{?with_openssl:--with-openssl=shared} \
        %{?with_kerberos5:--with-kerberos} \
        --with-tcadb=/usr \
@@ -2252,7 +2312,11 @@ cp -af Makefile.cli Makefile
 %endif
 
 %if %{with litespeed}
-%{__make} -f Makefile.litespeed
+%{__make} -f Makefile.litespeed litespeed
+%endif
+
+%if %{with embed}
+%{__make} -f Makefile.embed libphp5.la
 %endif
 
 # CGI/FCGI
@@ -2266,7 +2330,6 @@ cp -pf php_config.h.cgi-fcgi main/php_config.h
 %if %{with fpm}
 cp -pf php_config.h.fpm main/php_config.h
 %{__make} -f Makefile.fpm
-./sapi/fpm/php-fpm -n -m
 [ $(./sapi/fpm/php-fpm -n -m | grep cgi-fcgi) = "cgi-fcgi" ]
 %endif
 
@@ -2284,6 +2347,9 @@ install -d conf.d
 generate_inifiles() {
        for so in modules/*.so; do
                mod=$(basename $so .so)
+               ext=extension
+               # opcache.so is zend extension
+               nm $so | grep -q zend_extension_entry && ext=zend_extension
                conf="$mod.ini"
                # xml needs to be loaded before wddx
                [ "$mod" = "wddx" ] && conf="xml_$mod.ini"
@@ -2297,8 +2363,8 @@ generate_inifiles() {
                [ "$mod" = "mysqlnd" ] && conf="MySQLND.ini"
                echo "+ $conf"
                cat > conf.d/$conf <<-EOF
-                       ; Enable $mod extension module
-                       extension=$mod.so
+                       ; Enable $mod $ext module
+                       $ext=$mod.so
                EOF
        done
 }
@@ -2320,11 +2386,6 @@ cp -pf Makefile.cli Makefile
 exit 1
 %endif
 
-%if %{with tests}
-# Run tests, using the CLI SAPI
-cp -pf php_config.h.cli main/php_config.h
-cp -pf Makefile.cli Makefile
-
 cat <<'EOF' > run-tests.sh
 #!/bin/sh
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
@@ -2335,17 +2396,23 @@ unset TZ LANG LC_ALL || :
        RUN_TESTS_SETTINGS="-q $*"
 EOF
 chmod +x run-tests.sh
-./run-tests.sh -w failed.log -s test.log
+
+%if %{with tests}
+# Run tests, using the CLI SAPI
+cp -pf php_config.h.cli main/php_config.h
+cp -pf Makefile.cli Makefile
+
+./run-tests.sh -w failed.log -s tests.log
 
 # collect failed tests into cleanup script used in prep.
-sed -ne '/FAILED TEST SUMMARY/,/^===/p' test.log | sed -e '1,/^---/d;/^===/,$d' > tests-failed.log
-sed -ne '/\[.*\]/{s/\(.*\) \[\(.*\)\]/# \1\nmv \2{,.skip}/p}' tests-failed.log \
+sed -ne '/^FAILED TEST SUMMARY/,/^===/p' tests.log | sed -e '1,/^---/d;/^===/,$d' > tests-failed.log
+sed -ne '/^via/d;/\[.*\]/{s/\t*\(.*\) \[\(.*\)\]\(.*\)/# \1\3\nmv \2{,.skip}/p}' tests-failed.log \
        >> %{_sourcedir}/skip-tests.sh
 
-failed=$(wc -l < tests-failed.log)
-if [ "$failed" != 0 ]; then
-       exit 1
-fi
+# if on builders, dump test log
+tty -q || cat tests.log
+
+test ! -s failed.log
 %endif
 
 %install
@@ -2358,19 +2425,27 @@ install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache{,1}},%{_sysconfdir}/{apache,cg
 cp -pf php_config.h.cli main/php_config.h
 cp -pf Makefile.cli Makefile
 %{__make} install \
+       phpbuilddir=%{_libdir}/%{name}/build \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
 # make link relative
 ln -sfn phar.phar $RPM_BUILD_ROOT%{_bindir}/phar
 
+# version suffix
+v=$(echo %{version} | cut -d. -f1-2)
+
 # install Apache1 DSO module
 %if %{with apache1}
 libtool --mode=install install -p sapi/apache/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache1
+mv $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5{,-$v}.so
+ln -s libphp5-$v.so $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5.so
 %endif
 
 # install Apache2 DSO module
 %if %{with apache2}
 libtool --mode=install install -p sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache
+mv $RPM_BUILD_ROOT%{_libdir}/apache/libphp5{,-$v}.so
+ln -s libphp5-$v.so $RPM_BUILD_ROOT%{_libdir}/apache/libphp5.so
 %endif
 
 # install litespeed sapi
@@ -2394,30 +2469,37 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/fpm.d,%{_sbindir}}
 libtool --mode=install install -p sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}/%{name}-fpm
 cp -p sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}-fpm.8
 cp -p sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
+cp -p sapi/fpm/php-fpm.conf-d $RPM_BUILD_ROOT%{_sysconfdir}/fpm.d/www.conf
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm
+install -d $RPM_BUILD_ROOT/etc/logrotate.d
+cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
+%if "%{pld_release}" == "ac"
+%{__sed} -i -e '/su/d' $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
+%endif
+
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
        s#/etc/php#%{_sysconfdir}#
        s#@processname@#%{name}-fpm#g
-' $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fpm $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf
-install -d $RPM_BUILD_ROOT/etc/logrotate.d
-cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
+' $RPM_BUILD_ROOT{/etc/{rc.d/init.d/%{name}-fpm,logrotate.d/%{name}-fpm},%{_sysconfdir}/php-fpm.conf,%{_sysconfdir}/fpm.d/www.conf}
 %endif
 
 # install Embedded API
 %if %{with embed}
-%{__make} -f Makefile.embed install-sapi INSTALL_ROOT=$RPM_BUILD_ROOT
 # we could use install-headers from Makefile.embed, but that would reinstall all headers
+# install-sapi installs to wrong dir, so just do it all manually
 install -d $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
+install -p libs/libphp5.so $RPM_BUILD_ROOT%{_libdir}
 cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
 %endif
 
 # install CLI
-libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/%{name}
-cp -p sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
-echo ".so %{name}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
-ln -sf %{name} $RPM_BUILD_ROOT%{_bindir}/php
+# versioned suffix is always installed
+libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php%{ver_suffix}
+cp -p sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/php%{ver_suffix}.1
+echo ".so php%{ver_suffix}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
+ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
 
@@ -2437,7 +2519,7 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-apache2handler.ini
 %endif
 
 # ensure that paths are correct for current php version and arch
-grep -El '/etc/php/|/usr/lib/php/' %{_sysconfdir}/*.ini | xargs -r \
+grep -El '/etc/php/|/usr/lib/php/' $RPM_BUILD_ROOT%{_sysconfdir}/*.ini | xargs -r \
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
        s#/etc/php#%{_sysconfdir}#
@@ -2454,16 +2536,17 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/{conf.d/readline.ini,cli.d}
 
 # use system automake and {lib,sh}tool
 %if "%{pld_release}" != "ac"
-       ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/php/build
+       ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/%{name}/build
        for i in libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4; do
-               ln -snf %{_aclocaldir}/${i} $RPM_BUILD_ROOT%{_libdir}/php/build
+               ln -snf %{_aclocaldir}/${i} $RPM_BUILD_ROOT%{_libdir}/%{name}/build
        done
-       ln -snf %{_datadir}/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/php/build
+       ln -snf %{_datadir}/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/%{name}/build
 %else
-       ln -snf %{_aclocaldir}/libtool.m4 $RPM_BUILD_ROOT%{_libdir}/php/build
-       ln -snf %{_datadir}/libtool/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/php/build
+       ln -snf %{_aclocaldir}/libtool.m4 $RPM_BUILD_ROOT%{_libdir}/%{name}/build
+       ln -snf %{_datadir}/libtool/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/%{name}/build
 %endif
-ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/php/build
+ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/%{name}/build
+sed -i -e '/^phpdir/ s,/php/build,/%{name}/build,' $RPM_BUILD_ROOT%{_bindir}/phpize
 
 # for php-pecl-mailparse
 install -d $RPM_BUILD_ROOT%{_includedir}/php/ext/mbstring
@@ -2476,12 +2559,8 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common.la
-%if %{with embed}
-# libphp5.la contains our buildroot in dependency_libs
-sed -i -e "/dependency_libs/ s,/[^ ]*/libs/libphp_common.la,%{_libdir}/libphp_common.la," $RPM_BUILD_ROOT%{_libdir}/libphp5.la
-%endif
 # better solution?
-sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_libdir}/php/build/acinclude.m4
+sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_libdir}/%{name}/build/acinclude.m4
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -2595,6 +2674,7 @@ fi
 %extension_scripts mysqlnd
 %extension_scripts oci8
 %extension_scripts odbc
+%extension_scripts opcache
 %extension_scripts openssl
 %extension_scripts pcre
 %extension_scripts pdo
@@ -2641,6 +2721,7 @@ fi
 %dir %{_sysconfdir}/apache.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache.ini
 %attr(755,root,root) %{_libdir}/apache1/libphp5.so
+%attr(755,root,root) %{_libdir}/apache1/libphp5-*.*.so
 %endif
 
 %if %{with apache2}
@@ -2650,6 +2731,7 @@ fi
 %dir %{_sysconfdir}/apache2handler.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
 %attr(755,root,root) %{_libdir}/apache/libphp5.so
+%attr(755,root,root) %{_libdir}/apache/libphp5-*.*.so
 %endif
 
 %if %{with litespeed}
@@ -2670,15 +2752,15 @@ fi
 %if %{with embed}
 %files embedded
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libphp5-%{version}.so
+%attr(755,root,root) %{_libdir}/libphp5.so
 %endif
 
 %files cli
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/cli.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-cli.ini
-%attr(755,root,root) %{_bindir}/%{name}
-%{_mandir}/man1/%{name}.1*
+%attr(755,root,root) %{_bindir}/php%{ver_suffix}
+%{_mandir}/man1/php%{ver_suffix}.1*
 
 %files program
 %defattr(644,root,root,755)
@@ -2691,6 +2773,7 @@ fi
 %doc sapi/fpm/{CREDITS,LICENSE}
 %dir %{_sysconfdir}/fpm.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-fpm.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fpm.d/www.conf
 %attr(755,root,root) %{_sbindir}/%{name}-fpm
 %{_mandir}/man8/%{name}-fpm.8*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}-fpm
@@ -2717,14 +2800,9 @@ fi
 %attr(755,root,root) %{_libdir}/libphp_common.so
 %{_libdir}/libphp_common.la
 %{_includedir}/php
-%{_libdir}/php/build
+%{_libdir}/%{name}/build
 %{_mandir}/man1/php-config.1*
 %{_mandir}/man1/phpize.1*
-%if %{with embed}
-# embedded
-%{_libdir}/libphp5.so
-%{_libdir}/libphp5.la
-%endif
 
 %files bcmath
 %defattr(644,root,root,755)
@@ -2769,11 +2847,13 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/dom.ini
 %attr(755,root,root) %{php_extensiondir}/dom.so
 
+%if %{with enchant}
 %files enchant
 %defattr(644,root,root,755)
 %doc ext/enchant/{CREDITS,docs/examples}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/enchant.ini
 %attr(755,root,root) %{php_extensiondir}/enchant.so
+%endif
 
 %files exif
 %defattr(644,root,root,755)
@@ -2914,7 +2994,7 @@ fi
 %if %{with oci8}
 %files oci8
 %defattr(644,root,root,755)
-%doc ext/ico8/{CREDITS,README}
+%doc ext/oci8/{CREDITS,README}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/oci8.ini
 %attr(755,root,root) %{php_extensiondir}/oci8.so
 %endif
@@ -2927,6 +3007,14 @@ fi
 %attr(755,root,root) %{php_extensiondir}/odbc.so
 %endif
 
+%if %{with opcache}
+%files opcache
+%defattr(644,root,root,755)
+%doc ext/opcache/README
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/opcache.ini
+%attr(755,root,root) %{php_extensiondir}/opcache.so
+%endif
+
 %if %{with openssl}
 %files openssl
 %defattr(644,root,root,755)
@@ -3025,6 +3113,8 @@ fi
 %attr(755,root,root) %{php_extensiondir}/phar.so
 %attr(755,root,root) %{_bindir}/phar
 %attr(755,root,root) %{_bindir}/phar.phar
+%{_mandir}/man1/phar.1*
+%{_mandir}/man1/phar.phar.1
 %endif
 
 %files posix
This page took 0.069759 seconds and 4 git commands to generate.