]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- added mysqli support
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
8c91402c
AM
3# - think of including support for:
4# - mcve,
5# - ovrimos,
6# - pfpro,
7# - ircg,
8# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
9# - deal with modules removed from php and not moved to PECL
10# (existing only in php4):
b673897a 11# db, domxml, hyperwave, java, mcal, overload, qtdom, xslt
1ffa7abd
JB
12# - enabling sybase+sybase_ct+mssql together causes SEGV beside warnings
13# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 14# - make additional headers added by mail patch configurable
82bb3a40 15#
6f91d99f
JB
16# Conditional build:
17%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 18%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
4f8ad92f 19%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
28106fe7 20%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 21%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
22%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
23%bcond_with oracle # with oracle extension module (BR: proprietary libs)
8b37a21e 24%bcond_with mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f
JB
25%bcond_without cpdf # without cpdf extension module
26%bcond_without curl # without CURL extension module
8c91402c 27%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f
JB
28%bcond_without imap # without IMAP extension module
29%bcond_without interbase # without InterBase extension module
30%bcond_without ldap # without LDAP extension module
31%bcond_without mhash # without mhash extension module
32%bcond_without ming # without ming extension module
33%bcond_without mm # without mm support for session storage
34%bcond_without mnogosearch # without mnogosearch extension module
35%bcond_without msession # without msession extension module
36%bcond_without mssql # without MS SQL extension module
37%bcond_without odbc # without ODBC extension module
38%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
39%bcond_without pcre # without PCRE extension module
6f91d99f 40%bcond_without pgsql # without PostgreSQL extension module
274395e3 41%bcond_without pspell # without pspell extension module
6f91d99f 42%bcond_without recode # without recode extension module
6f91d99f 43%bcond_without snmp # without SNMP extension module
8c91402c 44%bcond_without sqlite # without SQLite extension module
41a6f471 45%bcond_without sybase # without Sybase extension module
4cc60252 46%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 47%bcond_without tidy # without Tidy extension module
6f91d99f
JB
48%bcond_without wddx # without WDDX extension module
49%bcond_without xmlrpc # without XML-RPC extension module
6f91d99f 50#
c2388c7d 51%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
41a9af21 52%define apxs /usr/sbin/apxs
6f91d99f 53# some problems with apache 2.x
ab092fe1 54%if %{_apache2}
6f91d99f 55%undefine with_mm
ab092fe1 56%endif
c37dabc8 57%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
6f91d99f 58%undefine with_interbase
52bba439 59%endif
6e4962cf 60# x86-only lib
52bba439 61%ifnarch %{ix86}
6f91d99f 62%undefine with_msession
c2388c7d 63%endif
6f91d99f 64%include /usr/lib/rpm/macros.php
caff8ce9 65Summary: The PHP HTML-embedded scripting language for use with Apache
66Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 67