]> git.pld-linux.org Git - packages/php.git/blame_incremental - php.spec
- added mysqli support
[packages/php.git] / php.spec
... / ...
CommitLineData
1#
2# TODO:
3# - think of including support for:
4# - mcve,
5# - ovrimos,
6# - pfpro,
7# - ircg,
8# These extensions BuildRequires proprietary libraries...
9# - deal with modules removed from php and not moved to PECL
10# (existing only in php4):
11# db, domxml, hyperwave, java, mcal, overload, qtdom, xslt
12# - enabling sybase+sybase_ct+mssql together causes SEGV beside warnings
13# - mime_magic can't handle new "string/*" entries in magic.mime
14# - make additional headers added by mail patch configurable
15#
16# Conditional build:
17%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
18%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
19%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
20%bcond_with hwapi # with Hw API support (BR: proprietary libs)
21%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
22%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
23%bcond_with oracle # with oracle extension module (BR: proprietary libs)
24%bcond_with mysqli # with mysqli support (Requires mysql > 4.1)
25%bcond_without cpdf # without cpdf extension module
26%bcond_without curl # without CURL extension module
27%bcond_without fam # without FAM (File Alteration Monitor) extension module
28%bcond_without imap # without IMAP extension module
29%bcond_without interbase # without InterBase extension module
30%bcond_without ldap # without LDAP extension module
31%bcond_without mhash # without mhash extension module
32%bcond_without ming # without ming extension module
33%bcond_without mm # without mm support for session storage
34%bcond_without mnogosearch # without mnogosearch extension module
35%bcond_without msession # without msession extension module
36%bcond_without mssql # without MS SQL extension module
37%bcond_without odbc # without ODBC extension module
38%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
39%bcond_without pcre # without PCRE extension module
40%bcond_without pgsql # without PostgreSQL extension module
41%bcond_without pspell # without pspell extension module
42%bcond_without recode # without recode extension module
43%bcond_without snmp # without SNMP extension module
44%bcond_without sqlite # without SQLite extension module
45%bcond_without sybase # without Sybase extension module
46%bcond_without sybase_ct # without Sybase-CT extension module
47%bcond_without tidy # without Tidy extension module
48%bcond_without wddx # without WDDX extension module
49%bcond_without xmlrpc # without XML-RPC extension module
50#
51%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
52%define apxs /usr/sbin/apxs
53# some problems with apache 2.x
54%if %{_apache2}
55%undefine with_mm
56%endif
57%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
58%undefine with_interbase
59%endif
60# x86-only lib
61%ifnarch %{ix86}
62%undefine with_msession
63%endif
64%include /usr/lib/rpm/macros.php
65Summary: The PHP HTML-embedded scripting language for use with Apache
66Summary(fr): Le langage de script embarque-HTML PHP pour Apache
67