]> git.pld-linux.org Git - packages/php-rrdtool.git/blob - php-rrdtool.spec
this one is not maintained, use pecl instead
[packages/php-rrdtool.git] / php-rrdtool.spec
1 # NOTE
2 # - use http://pecl.php.net/package/rrd instead
3 %define         php_name        php%{?php_suffix}
4 %define         modname rrdtool
5 Summary:        RRDtool PHP module
6 Summary(pl.UTF-8):      Moduł PHP RRDtool
7 Name:           %{php_name}-%{modname}
8 Version:        1.2
9 Release:        8
10 License:        GPL
11 Group:          Applications/Databases
12 Source0:        http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/contrib/php_rrdtool.tgz
13 # Source0-md5:  c86a45cfc54517b9066c480bbc589d43
14 URL:            http://oss.oetiker.ch/rrdtool/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.4
16 BuildRequires:  rpmbuild(macros) >= 1.322
17 BuildRequires:  rrdtool-devel >= 1.2.10
18 BuildRequires:  sed >= 4.0
19 %{?requires_php_extension}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package includes a dynamic shared object (DSO) that adds RRDtool
24 bindings to the PHP HTML-embedded scripting language.
25
26 %description -l pl.UTF-8
27 Ten pakiet zawiera dynamiczny moduł (DSO) dodający dowiązania RRDtoola
28 do języka skryptowego PHP.
29
30 %prep
31 %setup -q -n rrdtool
32
33 sed -i -e 's,/lib\>,/%{_lib},' config.m4
34
35 %build
36 phpize
37 %configure \
38         --with-rrdtool=shared
39
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
45 %{__make} install \
46         INSTALL_ROOT=$RPM_BUILD_ROOT
47
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49 ; Enable %{modname} extension module
50 extension=%{modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.111541 seconds and 3 git commands to generate.