]> git.pld-linux.org Git - packages/php-redis.git/blob - php-redis.spec
- obsolete old php name
[packages/php-redis.git] / php-redis.spec
1 # TODO
2 # - use external igbinary and make it's dependency optional
3 #
4 # Conditional build:
5 %bcond_without  tests           # build without tests
6
7 %define         php_name        php%{?php_suffix}
8 %define         modname redis
9 Summary:        %{modname} A PHP extension for Redis
10 Name:           %{php_name}-%{modname}
11 Version:        2.2.5
12 Release:        2
13 License:        PHP 3.01
14 Group:          Development/Languages/PHP
15 Source0:        https://github.com/nicolasff/phpredis/tarball/%{version}/%{modname}-%{version}.tar.gz
16 # Source0-md5:  0e82aed77f2c23a9072b277ecdef6dba
17 Source1:        https://github.com/ukko/phpredis-phpdoc/tarball/master/%{modname}-phpdoc.tgz
18 # Source1-md5:  b7cce5ee29c6597e0fdd3557397e1b2a
19 URL:            https://github.com/nicolasff/phpredis
20 BuildRequires:  %{php_name}-devel >= 4:5.0.4
21 %{?with_tests:BuildRequires:    %{php_name}-session}
22 %{?with_tests:BuildRequires:    %{php_name}-simplexml}
23 %{?with_tests:BuildRequires:    /usr/bin/php}
24 BuildRequires:  rpmbuild(macros) >= 1.519
25 %{?requires_php_extension}
26 Requires:       %{php_name}-session
27 Obsoletes:      php-redis < 2.2.5-1
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The phpredis extension provides an API for communicating with the
32 Redis key-value store.
33
34 This extension also provides session support.
35
36 %prep
37 %setup -qc -a1
38 mv nicolasff-php%{modname}-*/* .
39 mv ukko-phpredis-phpdoc-* phpdoc
40
41 %build
42 phpize
43 %configure
44 %{__make}
45
46 %if %{with tests}
47 # simple module load test
48 %{__php} -n \
49         -dextension_dir=modules \
50         -dextension=%{php_extensiondir}/simplexml.so \
51         -dextension=%{php_extensiondir}/spl.so \
52         -dextension=%{php_extensiondir}/session.so \
53         -dextension=%{modname}.so \
54         -m > modules.log
55 grep %{modname} modules.log
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         EXTENSION_DIR=%{php_extensiondir} \
62         INSTALL_ROOT=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
65 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
66 ; Enable %{modname} extension module
67 extension=%{modname}.so
68 EOF
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 %php_webserver_restart
75
76 %postun
77 if [ "$1" = 0 ]; then
78         %php_webserver_restart
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc CREDITS README.markdown phpdoc
84 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
85 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.085812 seconds and 4 git commands to generate.