]> git.pld-linux.org Git - packages/php-pecl-zendopcache.git/blob - php-pecl-zendopcache.spec
provide also php(opcache) dependency
[packages/php-pecl-zendopcache.git] / php-pecl-zendopcache.spec
1 # NOTE:
2 # This version of Zend OPcache is compatible with PHP 5.2.*, 5.3.*, 5.4.*
3 # and PHP-5.5 development branch. PHP 5.2 support may be removed in the future.
4 %define         php_name        php%{?php_suffix}
5 %define         modname zendopcache
6 Summary:        Zend Optimizer+ - PHP code optimizer
7 Summary(pl.UTF-8):      Zend Optimizer+ - optymalizator kodu PHP
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        7.0.5
10 Release:        2
11 License:        PHP 3.01
12 Group:          Development/Languages/PHP
13 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
14 # Source0-md5:  0c2710c272e398bea89d41dee42ee633
15 Source1:        %{modname}.ini
16 URL:            https://pecl.php.net/package/zendopcache
17 BuildRequires:  %{php_name}-devel >= 4:5.2
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 %{?requires_php_extension}
20 Provides:       php(opcache) = %{version}
21 Provides:       php(zendopcache) = %{version}
22 Obsoletes:      php-pecl-zendopcache < 7.0.3-1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Zend OPcache provides faster PHP execution through opcode caching
27 and optimization. It improves PHP performance by storing precompiled
28 script bytecode in the shared memory. This eliminates the stages of
29 reading code from the disk and compiling it on future access. In
30 addition, it applies a few bytecode optimization patterns that make
31 code execution faster.
32
33 %prep
34 %setup -qc
35 mv %{modname}-%{version}/* .
36
37 if [ %{php_major_version} -ge 5 -a %{php_minor_version} -ge 5 ]; then
38         echo >&2 "pointless to build, PHP >= 5.5 has php-opcache package"
39         exit 1
40 fi
41
42 %build
43 phpize
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %{__make} install \
50         EXTENSION_DIR=%{php_extensiondir} \
51         INSTALL_ROOT=$RPM_BUILD_ROOT
52
53 # NOTE: In case you are going to use Zend OPcache together with Xdebug,
54 # be sure that Xdebug is loaded after OPcache. "php -v" must show Xdebug
55 # after OPcache.
56 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
57 sed -e 's,@extensiondir@,%{php_extensiondir},' %{SOURCE1} > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 %php_webserver_restart
64
65 %postun
66 if [ "$1" = 0 ]; then
67         %php_webserver_restart
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README LICENSE
73 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
74 %attr(755,root,root) %{php_extensiondir}/opcache.so
This page took 0.050792 seconds and 3 git commands to generate.