]> git.pld-linux.org Git - packages/php-pecl-xslcache.git/commitdiff
- initial auto/th/php-pecl-xslcache-0_7_1-1
authoramateja <amateja@pld-linux.org>
Sat, 16 Jan 2010 12:28:28 +0000 (12:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-pecl-xslcache.spec -> 1.1

php-pecl-xslcache.spec [new file with mode: 0644]

diff --git a/php-pecl-xslcache.spec b/php-pecl-xslcache.spec
new file mode 100644 (file)
index 0000000..d54606c
--- /dev/null
@@ -0,0 +1,77 @@
+#
+# Conditional build:
+%bcond_without tests           # build without tests
+
+%define                modname xslcache
+Summary:       %{modname} - A modification of PHP's standard XSL extension that caches the parsed XSL stylesheet representation
+Summary(pl.UTF-8):     %{modname} - modyfikacja standardowego rozszerzenia XSL PHP, które buforuje przetworzone reprezentacje arkuszów stylów XSL
+Name:          php-pecl-%{modname}
+Version:       0.7.1
+Release:       1
+License:       PHP 3.01
+Group:         Development/Languages/PHP
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
+# Source0-md5: 1e32327f62122055ece6f78fa2b851b2
+URL:           http://pecl.php.net/package/xslcache
+BuildRequires: libxslt
+BuildRequires: php-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.519
+%{?requires_php_extension}
+Requires:      php-common >= 4:5.0.4
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The XSL Cache extension is a modification of PHP's standard XSL
+extension that caches the parsed XSL stylesheet representation between
+sessions for 2.5x boost in performance for sites that repeatedly apply
+the same transform. Although there is still some further work that
+could be done on the extension, this code is already proving
+beneficial in production use for a few applications on the New York
+Times' website.
+
+#%description -l pl.UTF-8
+
+%prep
+%setup -q -c
+mv %{modname}-%{version}/* .
+
+%build
+phpize
+%configure \
+       --with-xslcache=%{_libdir} \
+       --with-xsl-exsl-dir=%{_libdir}
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+#install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
+#install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
+
+%{__make} install \
+       INSTALL_ROOT=$RPM_BUILD_ROOT \
+       EXTENSION_DIR=%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
+EOF
+
+#cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%php_webserver_restart
+
+%postun
+if [ "$1" = 0 ]; then
+       %php_webserver_restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc CREDITS EXPERIMENTAL
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
+#%{_examplesdir}/%{name}-%{version}
This page took 0.096569 seconds and 4 git commands to generate.