]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- up to 2.0.0 beta2, include client binary (subpackage sounds good here)
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3
4 Summary:        %{_modname} - provides functions for functions traces and profiling
5 Summary(pl):    %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
6 Name:           php-pecl-%{_modname}
7 Version:        2.0.0
8 %define _snap   beta2
9 Release:        0.%{_snap}.1
10 License:        BSD style
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}%{_snap}.tgz
13 # Source0-md5:  e2fc53f2a7ee87cee9aab200bb17ae73
14 URL:            http://pecl.php.net/package/xdebug/
15 BuildRequires:  libedit-devel
16 BuildRequires:  libtool
17 BuildRequires:  php-devel
18 Requires:       php-common
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/php
23 %define         extensionsdir   %{_libdir}/php
24
25 %description
26 The Xdebug extension helps you debugging your script by providing a
27 lot of valuable debug information. The debug information that Xdebug
28 can provide includes the following:
29
30 - stack and function traces in error messages with:
31         - full parameter display for user defined functions
32         - function name, file name and line indications
33         - support for member functions
34           memory allocation
35 - protection for infinite recursions
36
37 Xdebug also provides:
38
39 - profiling information for PHP scripts
40 - script execution analysis
41 - capabilities to debug your scripts interactively with a debug client
42
43 In PECL status of this package is: %{_status}.
44
45 %description -l pl
46 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczaj±c
47 du¿o warto¶ciowych informacji. Informacje przydatne do ¶ledzenia,
48 które mo¿e zapewniæ Xdebug, obejmuj±:
49
50 - ¶ledzenie stosu i funkcji w komunikatach b³êdów wraz z:
51         - pe³nym wy¶wietlaniem parametrów dla funkcji zdefiniowanych przez
52           u¿ytkownika
53         - nazwami funkcji, nazwami plików i numerami linii
54         - obs³ug± metod klas
55 - przydzielanie pamiêci
56 - zabezpieczenie przed nieskoñczon± rekurencj±
57
58 Xdebug dostarcza tak¿e:
59
60 - informacje do profilowania skryptów PHP
61 - analizê wywo³añ skryptu
62 - mo¿liwo¶æ ¶ledzenia skryptów interaktywnie przy pomocy klienta
63   odpluskwiacza
64
65 To rozszerzenie ma w PECL status: %{_status}.
66
67 %prep
68 %setup -q -c
69
70 %build
71 cd %{_modname}-%{version}%{_snap}
72 phpize
73 %configure
74 %{__make}
75 cd debugclient
76 install %{_datadir}/automake/config.* .
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %configure \
81         --with-libedit
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_bindir},%{extensionsdir}}
87
88 install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
89 install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
96
97 %preun
98 if [ "$1" = "0" ]; then
99         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc %{_modname}-*/{README,NEWS,Changelog,CREDITS}
105 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
106 %attr(755,root,root) %{_bindir}/*
This page took 0.037897 seconds and 4 git commands to generate.