]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- it finally happened - PECL separated from PEAR and moved to its own
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         beta
3 %define         _rc             rc1
4 Summary:        %{_modname} - provides functions for functions traces and profiling
5 Summary(pl):    %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
6 Name:           php-pecl-%{_modname}
7 Version:        1.3.0
8 Release:        0.%{_rc}
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}%{_rc}.tgz
12 # Source0-md5:  f4077d26281c339e1339d942f0d1788b
13 URL:            http://pecl.php.net/package/xdebug/
14 BuildRequires:  libtool
15 BuildRequires:  php-devel
16 Requires:       php-common
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 %{_modname} provides functions for function tracing, memory usage and
25 profiling.
26
27 This extension has in PEAR status: %{_status}.
28
29 %description -l pl
30 %{_modname} dostarcza funkcje do ¶ledzienia funkcji i wykorzystania
31 pamiêci oraz profilowania.
32
33 To rozszerzenie ma w PEAR status: %{_status}.
34
35 %prep
36 %setup -q -c
37
38 %build
39 cd %{_modname}-%{version}%{_rc}
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{extensionsdir}
47
48 install %{_modname}-%{version}%{_rc}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
55
56 %preun
57 if [ "$1" = "0" ]; then
58         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc %{_modname}-%{version}%{_rc}/{README,NEWS,Changelog,CREDITS}
64 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.176741 seconds and 4 git commands to generate.