]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- updated to 2.1.3
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         modname xdebug
2 %define         status  stable
3 Summary:        %{modname} - provides functions for functions traces and profiling
4 Summary(pl.UTF-8):      %{modname} - funkcje do śledzenia i profilowania funkcji
5 Name:           php-pecl-%{modname}
6 Version:        2.1.3
7 Release:        1
8 License:        BSD style
9 Group:          Development/Languages/PHP
10 Source0:        http://www.xdebug.org/files/xdebug-%{version}.tgz
11 # Source0-md5:  601128a91dea4f315330ce3f7ddcc3d8
12 Source1:        %{name}.ini
13 URL:            http://www.xdebug.org/
14 BuildRequires:  libedit-devel
15 BuildRequires:  libtool
16 BuildRequires:  php-devel >= 4:5.3.0
17 BuildRequires:  rpmbuild(macros) >= 1.579
18 %{?requires_zend_extension}
19 Conflicts:      ZendOptimizer
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The Xdebug extension helps you debugging your script by providing a
24 lot of valuable debug information. The debug information that Xdebug
25 can provide includes the following:
26
27 - stack and function traces in error messages with:
28  - full parameter display for user defined functions
29  - function name, file name and line indications
30  - support for member functions memory allocation
31 - protection for infinite recursions
32
33 Xdebug also provides:
34
35 - profiling information for PHP scripts
36 - script execution analysis
37 - capabilities to debug your scripts interactively with a debug client
38
39 In PECL status of this package is: %{status}.
40
41 %description -l pl.UTF-8
42 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
43 dużo wartościowych informacji. Informacje przydatne do śledzenia,
44 które może zapewnić Xdebug, obejmują:
45
46 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
47  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
48    użytkownika
49  - nazwami funkcji, nazwami plików i numerami linii
50  - obsługą metod klas
51 - przydzielanie pamięci
52 - zabezpieczenie przed nieskończoną rekurencją
53
54 Xdebug dostarcza także:
55
56 - informacje do profilowania skryptów PHP
57 - analizę wywołań skryptu
58 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
59   odpluskwiacza
60
61 To rozszerzenie ma w PECL status: %{status}.
62
63 %prep
64 %setup -qc
65 mv %{modname}-%{version}*/* .
66 chmod +x debugclient/configure
67
68 %{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
69
70 %build
71 # libtool 2.2 build fix
72 if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
73         cat %{_aclocaldir}/ltsugar.m4 >> config.m4
74         cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
75
76         cat %{_aclocaldir}/ltversion.m4 >> config.m4
77         cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
78
79         cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
80         cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
81
82         cat %{_aclocaldir}/ltoptions.m4 >> config.m4
83         cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
84
85         cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
86 fi
87
88 phpize
89 %configure
90 %{__make}
91 cd debugclient
92 install /usr/share/automake/{config.*,depcomp} .
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %configure \
97         --with-libedit
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
103
104 install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}-debugclient
105 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
106 cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %php_webserver_restart
113
114 %postun
115 if [ "$1" = 0 ]; then
116         %php_webserver_restart
117 fi
118
119 %files
120 %defattr(644,root,root,755)
121 %doc README NEWS Changelog CREDITS contrib/xt.vim
122 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
123 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
124 %attr(755,root,root) %{_bindir}/xdebug-debugclient
This page took 0.031314 seconds and 4 git commands to generate.