]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- rel .2
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5 Summary:        %{_modname} - provides functions for functions traces and profiling
6 Summary(pl):    %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
7 Name:           php-pecl-%{_modname}
8 Version:        2.0.0
9 %define _snap   beta5
10 %define _rel    2
11 Release:        0.%{_snap}.%{_rel}
12 License:        BSD style
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_modname}-%{version}%{_snap}.tgz
15 # Source0-md5:  3aa38da6a75923bd9560c69b63faa37d
16 Patch0:         %{name}-gcc4.patch
17 URL:            http://pecl.php.net/package/xdebug/
18 BuildRequires:  libedit-devel
19 BuildRequires:  libtool
20 BuildRequires:  php-devel >= 3:5.0.0
21 BuildRequires:  rpmbuild(macros) >= 1.254
22 Requires:       %{_sysconfdir}/conf.d
23 %{?requires_zend_extension}
24 Conflicts:      ZendOptimizer
25 Obsoletes:      php-pear-%{_modname}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Xdebug extension helps you debugging your script by providing a
30 lot of valuable debug information. The debug information that Xdebug
31 can provide includes the following:
32
33 - stack and function traces in error messages with:
34  - full parameter display for user defined functions
35  - function name, file name and line indications
36  - support for member functions memory allocation
37 - protection for infinite recursions
38
39 Xdebug also provides:
40
41 - profiling information for PHP scripts
42 - script execution analysis
43 - capabilities to debug your scripts interactively with a debug client
44
45 In PECL status of this package is: %{_status}.
46
47 %description -l pl
48 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczaj±c
49 du¿o warto¶ciowych informacji. Informacje przydatne do ¶ledzenia,
50 które mo¿e zapewniæ Xdebug, obejmuj±:
51
52 - ¶ledzenie stosu i funkcji w komunikatach b³êdów wraz z:
53  - pe³nym wy¶wietlaniem parametrów dla funkcji zdefiniowanych przez
54    u¿ytkownika
55  - nazwami funkcji, nazwami plików i numerami linii
56  - obs³ug± metod klas
57 - przydzielanie pamiêci
58 - zabezpieczenie przed nieskoñczon± rekurencj±
59
60 Xdebug dostarcza tak¿e:
61
62 - informacje do profilowania skryptów PHP
63 - analizê wywo³añ skryptu
64 - mo¿liwo¶æ ¶ledzenia skryptów interaktywnie przy pomocy klienta
65   odpluskwiacza
66
67 To rozszerzenie ma w PECL status: %{_status}.
68
69 %prep
70 %setup -q -c
71 %patch0 -p0
72 chmod +x %{_modname}-%{version}%{_snap}/debugclient/configure
73
74 %build
75 cd %{_modname}-%{version}%{_snap}
76 phpize
77 %configure
78 %{__make}
79 cd debugclient
80 install /usr/share/automake/config.* .
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %configure \
85         --with-libedit
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/conf.d,%{extensionsdir}}
91
92 install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
93 install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
94 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
95 ; Enable %{_modname} extension module
96 zend_extension%{?zend_zts:_ts}=%{extensionsdir}/%{_modname}.so
97 EOF
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
104 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
105
106 %postun
107 if [ "$1" = 0 ]; then
108         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
109         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
110 fi
111
112 %files
113 %defattr(644,root,root,755)
114 %doc %{_modname}-*/{README,NEWS,Changelog,CREDITS,xt.vim}
115 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
116 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
117 %attr(755,root,root) %{_bindir}/*
This page took 0.071475 seconds and 4 git commands to generate.