]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- updated to 1.3.1
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3
4 Summary:        %{_modname} - provides functions for functions traces and profiling
5 Summary(pl):    %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
6 Name:           php-pecl-%{_modname}
7 Version:        1.3.1
8 Release:        1
9 License:        BSD style
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  942bc3ea3e0951dc37c08ada3a3c9029
13 URL:            http://pecl.php.net/package/xdebug/
14 BuildRequires:  libtool
15 BuildRequires:  php-devel
16 Requires:       php-common
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 The Xdebug extension helps you debugging your script by providing a
25 lot of valuable debug information. The debug information that Xdebug
26 can provide includes the following:
27
28 - stack and function traces in error messages with:
29   - full parameter display for user defined functions
30   - function name, file name and line indications
31   - support for member functions
32 - memory allocation
33 - protection for infinite recursions
34
35 Xdebug also provides:
36
37 - profiling information for PHP scripts
38 - script execution analysis
39 - capabilities to debug your scripts interactively with a debug client
40
41 This extension has in PECL status: %{_status}.
42
43 %description -l pl
44 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczaj±c
45 du¿o warto¶ciowych informacji. Informacje przydatne do ¶ledzenia,
46 które mo¿e zapewniæ Xdebug, obejmuj±:
47
48 - ¶ledzenie stosu i funkcji w komunikatach b³êdów wraz z:
49   - pe³nym wy¶wietlaniem parametrów dla funkcji zdefiniowanych przez
50     u¿ytkownika
51   - nazwami funkcji, nazwami plików i numerami linii
52   - obs³ug± metod klas
53 - przydzielanie pamiêci
54 - zabezpieczenie przed nieskoñczon± rekurencj±
55
56 Xdebug dostarcza tak¿e:
57
58 - informacje do profilowania skryptów PHP
59 - analizê wywo³añ skryptu
60 - mo¿liwo¶æ ¶ledzenia skryptów interaktywnie przy pomocy klienta
61   odpluskwiacza
62
63 To rozszerzenie ma w PECL status: %{_status}.
64
65 %prep
66 %setup -q -c
67
68 %build
69 cd %{_modname}-%{version}
70 phpize
71 %configure
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{extensionsdir}
77
78 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
85
86 %preun
87 if [ "$1" = "0" ]; then
88         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc %{_modname}-%{version}/{README,NEWS,Changelog,CREDITS}
94 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.065717 seconds and 4 git commands to generate.