]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
up to 2.2.5
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname xdebug
3 %define         status  stable
4 Summary:        %{modname} - provides functions for functions traces and profiling
5 Summary(pl.UTF-8):      %{modname} - funkcje do śledzenia i profilowania funkcji
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        2.2.5
8 Release:        1
9 License:        BSD style
10 Group:          Development/Languages/PHP
11 Source0:        http://www.xdebug.org/files/xdebug-%{version}.tgz
12 # Source0-md5:  7e571ce8eb6fa969fd8263969019849d
13 Source1:        %{modname}.ini
14 URL:            http://www.xdebug.org/
15 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
16 BuildRequires:  libedit-devel
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 %{?requires_zend_extension}
20 Provides:       php(%{modname}) = %{version}
21 Obsoletes:      php-pecl-xdebug < 2.2.4-1
22 Conflicts:      ZendOptimizer
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Xdebug extension helps you debugging your script by providing a
27 lot of valuable debug information. The debug information that Xdebug
28 can provide includes the following:
29
30 - stack and function traces in error messages with:
31  - full parameter display for user defined functions
32  - function name, file name and line indications
33  - support for member functions memory allocation
34 - protection for infinite recursions
35
36 Xdebug also provides:
37
38 - profiling information for PHP scripts
39 - script execution analysis
40 - capabilities to debug your scripts interactively with a debug client
41
42 In PECL status of this package is: %{status}.
43
44 %description -l pl.UTF-8
45 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
46 dużo wartościowych informacji. Informacje przydatne do śledzenia,
47 które może zapewnić Xdebug, obejmują:
48
49 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
50  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
51    użytkownika
52  - nazwami funkcji, nazwami plików i numerami linii
53  - obsługą metod klas
54 - przydzielanie pamięci
55 - zabezpieczenie przed nieskończoną rekurencją
56
57 Xdebug dostarcza także:
58
59 - informacje do profilowania skryptów PHP
60 - analizę wywołań skryptu
61 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
62   odpluskwiacza
63
64 To rozszerzenie ma w PECL status: %{status}.
65
66 %prep
67 %setup -qc
68 mv %{modname}-%{version}*/* .
69 chmod +x debugclient/configure
70
71 %{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
72
73 %build
74 # libtool 2.2 build fix
75 if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
76         cat %{_aclocaldir}/ltsugar.m4 >> config.m4
77         cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
78
79         cat %{_aclocaldir}/ltversion.m4 >> config.m4
80         cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
81
82         cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
83         cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
84
85         cat %{_aclocaldir}/ltoptions.m4 >> config.m4
86         cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
87
88         cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
89 fi
90
91 phpize
92 %configure
93 %{__make}
94 cd debugclient
95 install /usr/share/automake/{config.*,depcomp} .
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %configure \
100         --with-libedit
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
106
107 install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
108 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
109 cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 %php_webserver_restart
116
117 %postun
118 if [ "$1" = 0 ]; then
119         %php_webserver_restart
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README NEWS CREDITS contrib/xt.vim
125 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
126 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
127 %attr(755,root,root) %{_bindir}/xdebug*-debugclient
This page took 0.043751 seconds and 4 git commands to generate.