]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- up to 2.0.3 on HEAD
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5 Summary:        %{_modname} - provides functions for functions traces and profiling
6 Summary(pl.UTF-8):      %{_modname} - funkcje do śledzenia i profilowania funkcji
7 Name:           php-pecl-%{_modname}
8 Version:        2.0.3
9 Release:        1
10 License:        BSD style
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  0735584168c8c9f111252128d0076d7c
14 Source1:        %{name}.ini
15 URL:            http://pecl.php.net/package/xdebug/
16 BuildRequires:  libedit-devel
17 BuildRequires:  libtool
18 BuildRequires:  php-devel >= 3:5.0.0
19 BuildRequires:  rpmbuild(macros) >= 1.344
20 Requires:       %{_sysconfdir}/conf.d
21 %{?requires_zend_extension}
22 Conflicts:      ZendOptimizer
23 Obsoletes:      php-pear-%{_modname}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Xdebug extension helps you debugging your script by providing a
28 lot of valuable debug information. The debug information that Xdebug
29 can provide includes the following:
30
31 - stack and function traces in error messages with:
32  - full parameter display for user defined functions
33  - function name, file name and line indications
34  - support for member functions memory allocation
35 - protection for infinite recursions
36
37 Xdebug also provides:
38
39 - profiling information for PHP scripts
40 - script execution analysis
41 - capabilities to debug your scripts interactively with a debug client
42
43 In PECL status of this package is: %{_status}.
44
45 %description -l pl.UTF-8
46 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
47 dużo wartościowych informacji. Informacje przydatne do śledzenia,
48 które może zapewnić Xdebug, obejmują:
49
50 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
51  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
52    użytkownika
53  - nazwami funkcji, nazwami plików i numerami linii
54  - obsługą metod klas
55 - przydzielanie pamięci
56 - zabezpieczenie przed nieskończoną rekurencją
57
58 Xdebug dostarcza także:
59
60 - informacje do profilowania skryptów PHP
61 - analizę wywołań skryptu
62 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
63   odpluskwiacza
64
65 To rozszerzenie ma w PECL status: %{_status}.
66
67 %prep
68 %setup -q -c
69 chmod +x %{_modname}-%{version}/debugclient/configure
70 cp %{SOURCE1} %{_modname}.ini
71 sed -e 's#^;zend_extension.*#zend_extension%{?zend_zts:_ts}=%{extensionsdir}/%{_modname}.so#' -i %{_modname}.ini
72
73 %build
74 cd %{_modname}-%{version}
75 phpize
76 %configure
77 %{__make}
78 cd debugclient
79 install /usr/share/automake/{config.*,depcomp} .
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %configure \
84         --with-libedit
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/conf.d,%{extensionsdir}}
90
91 install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
92 install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
93 install %{_modname}.ini $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 %php_webserver_restart
100
101 %postun
102 if [ "$1" = 0 ]; then
103         %php_webserver_restart
104 fi
105
106 %files
107 %defattr(644,root,root,755)
108 %doc %{_modname}-*/{README,NEWS,Changelog,CREDITS,xt.vim}
109 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
110 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
111 %attr(755,root,root) %{_bindir}/*
This page took 0.047914 seconds and 4 git commands to generate.