]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname xdebug
3 %define         status  stable
4 Summary:        %{modname} - provides functions for functions traces and profiling
5 Summary(pl.UTF-8):      %{modname} - funkcje do śledzenia i profilowania funkcji
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        2.2.3
8 Release:        2
9 License:        BSD style
10 Group:          Development/Languages/PHP
11 Source0:        http://www.xdebug.org/files/xdebug-%{version}.tgz
12 # Source0-md5:  e49cec9861b45dc0b36eae33bf8a14fa
13 Source1:        %{modname}.ini
14 URL:            http://www.xdebug.org/
15 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
16 BuildRequires:  libedit-devel
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 %{?requires_zend_extension}
20 Provides:       php(%{modname}) = %{version}
21 Conflicts:      ZendOptimizer
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Xdebug extension helps you debugging your script by providing a
26 lot of valuable debug information. The debug information that Xdebug
27 can provide includes the following:
28
29 - stack and function traces in error messages with:
30  - full parameter display for user defined functions
31  - function name, file name and line indications
32  - support for member functions memory allocation
33 - protection for infinite recursions
34
35 Xdebug also provides:
36
37 - profiling information for PHP scripts
38 - script execution analysis
39 - capabilities to debug your scripts interactively with a debug client
40
41 In PECL status of this package is: %{status}.
42
43 %description -l pl.UTF-8
44 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
45 dużo wartościowych informacji. Informacje przydatne do śledzenia,
46 które może zapewnić Xdebug, obejmują:
47
48 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
49  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
50    użytkownika
51  - nazwami funkcji, nazwami plików i numerami linii
52  - obsługą metod klas
53 - przydzielanie pamięci
54 - zabezpieczenie przed nieskończoną rekurencją
55
56 Xdebug dostarcza także:
57
58 - informacje do profilowania skryptów PHP
59 - analizę wywołań skryptu
60 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
61   odpluskwiacza
62
63 To rozszerzenie ma w PECL status: %{status}.
64
65 %prep
66 %setup -qc
67 mv %{modname}-%{version}*/* .
68 chmod +x debugclient/configure
69
70 %{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
71
72 %build
73 # libtool 2.2 build fix
74 if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
75         cat %{_aclocaldir}/ltsugar.m4 >> config.m4
76         cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
77
78         cat %{_aclocaldir}/ltversion.m4 >> config.m4
79         cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
80
81         cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
82         cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
83
84         cat %{_aclocaldir}/ltoptions.m4 >> config.m4
85         cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
86
87         cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
88 fi
89
90 phpize
91 %configure
92 %{__make}
93 cd debugclient
94 install /usr/share/automake/{config.*,depcomp} .
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %configure \
99         --with-libedit
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
105
106 install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
107 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
108 cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %php_webserver_restart
115
116 %postun
117 if [ "$1" = 0 ]; then
118         %php_webserver_restart
119 fi
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README NEWS CREDITS contrib/xt.vim
124 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
125 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
126 %attr(755,root,root) %{_bindir}/xdebug*-debugclient
This page took 0.095191 seconds and 4 git commands to generate.