]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- up to 2.1.0 beta3
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5 %define         beta            beta3
6 Summary:        %{_modname} - provides functions for functions traces and profiling
7 Summary(pl.UTF-8):      %{_modname} - funkcje do śledzenia i profilowania funkcji
8 Name:           php-pecl-%{_modname}
9 Version:        2.1.0
10 Release:        0.%{beta}.1
11 License:        BSD style
12 Group:          Development/Languages/PHP
13 Source0:        http://www.xdebug.org/files/%{_modname}-%{version}%{beta}.tgz
14 # Source0-md5:  51eff76e85280ea14860bcf7dbffa899
15 Source1:        %{name}.ini
16 URL:            http://www.xdebug.org/
17 BuildRequires:  libedit-devel
18 BuildRequires:  libtool
19 BuildRequires:  php-devel >= 3:5.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.465
21 Requires:       %{_sysconfdir}/conf.d
22 %{?requires_zend_extension}
23 Conflicts:      ZendOptimizer
24 Obsoletes:      php-pear-%{_modname}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Xdebug extension helps you debugging your script by providing a
29 lot of valuable debug information. The debug information that Xdebug
30 can provide includes the following:
31
32 - stack and function traces in error messages with:
33  - full parameter display for user defined functions
34  - function name, file name and line indications
35  - support for member functions memory allocation
36 - protection for infinite recursions
37
38 Xdebug also provides:
39
40 - profiling information for PHP scripts
41 - script execution analysis
42 - capabilities to debug your scripts interactively with a debug client
43
44 In PECL status of this package is: %{_status}.
45
46 %description -l pl.UTF-8
47 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
48 dużo wartościowych informacji. Informacje przydatne do śledzenia,
49 które może zapewnić Xdebug, obejmują:
50
51 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
52  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
53    użytkownika
54  - nazwami funkcji, nazwami plików i numerami linii
55  - obsługą metod klas
56 - przydzielanie pamięci
57 - zabezpieczenie przed nieskończoną rekurencją
58
59 Xdebug dostarcza także:
60
61 - informacje do profilowania skryptów PHP
62 - analizę wywołań skryptu
63 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
64   odpluskwiacza
65
66 To rozszerzenie ma w PECL status: %{_status}.
67
68 %prep
69 %setup -q -c
70 mv %{_modname}-%{version}%{beta}/* .
71 rmdir %{_modname}-%{version}%{beta}
72 chmod +x debugclient/configure
73
74 sed -e 's#^;zend_extension.*#zend_extension%{?zend_zts:_ts}=%{extensionsdir}/%{_modname}.so#' %{SOURCE1} > %{_modname}.ini
75
76 %build
77 # libtool 2.2 build fix
78 if [ -f /usr/share/aclocal/ltsugar.m4 ]; then
79         cat /usr/share/aclocal/ltsugar.m4 >> config.m4
80         cat /usr/share/aclocal/ltsugar.m4 >> debugclient/aclocal.m4
81                                                                                                                                                                                                                                                                                                                                                                         
82         cat /usr/share/aclocal/ltversion.m4 >> config.m4
83         cat /usr/share/aclocal/ltversion.m4 >> debugclient/aclocal.m4
84                                                                                                                                                                                                                                                                                                                                                                         
85         cat /usr/share/aclocal/lt~obsolete.m4 >> config.m4
86         cat /usr/share/aclocal/lt~obsolete.m4 >> debugclient/aclocal.m4
87                                                                                                                                                                                                                                                                                                                                                                         
88         cat /usr/share/aclocal/ltoptions.m4 >> config.m4
89         cat /usr/share/aclocal/ltoptions.m4 >> debugclient/aclocal.m4
90                                                                                                                                                                                                                                                                                                                                                                         
91         cat /usr/share/aclocal/libtool.m4 >> debugclient/aclocal.m4
92 fi
93
94 phpize
95 %configure
96 %{__make}
97 cd debugclient
98 install /usr/share/automake/{config.*,depcomp} .
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %configure \
103         --with-libedit
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/conf.d,%{extensionsdir}}
109
110 install debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
111 install modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
112 install %{_modname}.ini $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 %php_webserver_restart
119
120 %postun
121 if [ "$1" = 0 ]; then
122         %php_webserver_restart
123 fi
124
125 %files
126 %defattr(644,root,root,755)
127 %doc README NEWS Changelog CREDITS xt.vim
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
129 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
130 %attr(755,root,root) %{_bindir}/*
This page took 0.06336 seconds and 4 git commands to generate.