]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- non-conflicting filename for debugclient
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname xdebug
3 %define         status  stable
4 Summary:        %{modname} - provides functions for functions traces and profiling
5 Summary(pl.UTF-8):      %{modname} - funkcje do śledzenia i profilowania funkcji
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        2.2.0
8 Release:        2
9 License:        BSD style
10 Group:          Development/Languages/PHP
11 Source0:        http://www.xdebug.org/files/xdebug-%{version}.tgz
12 # Source0-md5:  27d8ad8224ffab04d12eecb5997a4f5d
13 Source1:        %{modname}.ini
14 URL:            http://www.xdebug.org/
15 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
16 BuildRequires:  libedit-devel
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.579
19 %{?requires_zend_extension}
20 Conflicts:      ZendOptimizer
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Xdebug extension helps you debugging your script by providing a
25 lot of valuable debug information. The debug information that Xdebug
26 can provide includes the following:
27
28 - stack and function traces in error messages with:
29  - full parameter display for user defined functions
30  - function name, file name and line indications
31  - support for member functions memory allocation
32 - protection for infinite recursions
33
34 Xdebug also provides:
35
36 - profiling information for PHP scripts
37 - script execution analysis
38 - capabilities to debug your scripts interactively with a debug client
39
40 In PECL status of this package is: %{status}.
41
42 %description -l pl.UTF-8
43 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
44 dużo wartościowych informacji. Informacje przydatne do śledzenia,
45 które może zapewnić Xdebug, obejmują:
46
47 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
48  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
49    użytkownika
50  - nazwami funkcji, nazwami plików i numerami linii
51  - obsługą metod klas
52 - przydzielanie pamięci
53 - zabezpieczenie przed nieskończoną rekurencją
54
55 Xdebug dostarcza także:
56
57 - informacje do profilowania skryptów PHP
58 - analizę wywołań skryptu
59 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
60   odpluskwiacza
61
62 To rozszerzenie ma w PECL status: %{status}.
63
64 %prep
65 %setup -qc
66 mv %{modname}-%{version}*/* .
67 chmod +x debugclient/configure
68
69 %{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
70
71 %build
72 # libtool 2.2 build fix
73 if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
74         cat %{_aclocaldir}/ltsugar.m4 >> config.m4
75         cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
76
77         cat %{_aclocaldir}/ltversion.m4 >> config.m4
78         cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
79
80         cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
81         cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
82
83         cat %{_aclocaldir}/ltoptions.m4 >> config.m4
84         cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
85
86         cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
87 fi
88
89 phpize
90 %configure
91 %{__make}
92 cd debugclient
93 install /usr/share/automake/{config.*,depcomp} .
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %configure \
98         --with-libedit
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
104
105 install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
106 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
107 cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %php_webserver_restart
114
115 %postun
116 if [ "$1" = 0 ]; then
117         %php_webserver_restart
118 fi
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README NEWS CREDITS contrib/xt.vim
123 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
124 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
125 %attr(755,root,root) %{_bindir}/xdebug*-debugclient
This page took 0.092667 seconds and 4 git commands to generate.