]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- workaround for spec parser having macro undefined yet and not seeing BR
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5
6 Summary:        %{_modname} - provides functions for functions traces and profiling
7 Summary(pl):    %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
8 Name:           php-pecl-%{_modname}
9 Version:        2.0.0
10 %define _snap   beta2
11 Release:        0.%{_snap}.1
12 License:        BSD style
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_modname}-%{version}%{_snap}.tgz
15 # Source0-md5:  e2fc53f2a7ee87cee9aab200bb17ae73
16 URL:            http://pecl.php.net/package/xdebug/
17 BuildRequires:  libedit-devel
18 BuildRequires:  libtool
19 BuildRequires:  php-devel >= 3:5.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.238
21 Requires:       %{_sysconfdir}/conf.d
22 %{?requires_php_extension}
23 Obsoletes:      php-pear-%{_modname}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Xdebug extension helps you debugging your script by providing a
28 lot of valuable debug information. The debug information that Xdebug
29 can provide includes the following:
30
31 - stack and function traces in error messages with:
32  - full parameter display for user defined functions
33  - function name, file name and line indications
34  - support for member functions memory allocation
35 - protection for infinite recursions
36
37 Xdebug also provides:
38
39 - profiling information for PHP scripts
40 - script execution analysis
41 - capabilities to debug your scripts interactively with a debug client
42
43 In PECL status of this package is: %{_status}.
44
45 %description -l pl
46 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczaj±c
47 du¿o warto¶ciowych informacji. Informacje przydatne do ¶ledzenia,
48 które mo¿e zapewniæ Xdebug, obejmuj±:
49
50 - ¶ledzenie stosu i funkcji w komunikatach b³êdów wraz z:
51  - pe³nym wy¶wietlaniem parametrów dla funkcji zdefiniowanych przez
52    u¿ytkownika
53  - nazwami funkcji, nazwami plików i numerami linii
54  - obs³ug± metod klas
55 - przydzielanie pamiêci
56 - zabezpieczenie przed nieskoñczon± rekurencj±
57
58 Xdebug dostarcza tak¿e:
59
60 - informacje do profilowania skryptów PHP
61 - analizê wywo³añ skryptu
62 - mo¿liwo¶æ ¶ledzenia skryptów interaktywnie przy pomocy klienta
63   odpluskwiacza
64
65 To rozszerzenie ma w PECL status: %{_status}.
66
67 %prep
68 %setup -q -c
69
70 %build
71 cd %{_modname}-%{version}%{_snap}
72 phpize
73 %configure
74 %{__make}
75 cd debugclient
76 install %{_datadir}/automake/config.* .
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %configure \
81         --with-libedit
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/conf.d,%{extensionsdir}}
87
88 install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
89 install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
90 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
91 ; Enable %{_modname} extension module
92 extension=%{_modname}.so
93 EOF
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
100 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
101
102 %postun
103 if [ "$1" = 0 ]; then
104         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
105         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc %{_modname}-*/{README,NEWS,Changelog,CREDITS}
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
112 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
113 %attr(755,root,root) %{_bindir}/*
This page took 0.118425 seconds and 4 git commands to generate.