]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
- add Conflicts due to
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 %define         _modname        xdebug
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5
6 Summary:        %{_modname} - provides functions for functions traces and profiling
7 Summary(pl):    %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
8 Name:           php-pecl-%{_modname}
9 Version:        2.0.0
10 %define _snap   beta3
11 Release:        0.%{_snap}.3
12 License:        BSD style
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_modname}-%{version}%{_snap}.tgz
15 # Source0-md5:  05a688515e37f93552333f7f3e95402f
16 URL:            http://pecl.php.net/package/xdebug/
17 BuildRequires:  libedit-devel
18 BuildRequires:  libtool
19 BuildRequires:  php-devel >= 3:5.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.238
21 Requires:       %{_sysconfdir}/conf.d
22 %{?requires_zend_extension}
23 Conflicts:      ZendOptimizer
24 Obsoletes:      php-pear-%{_modname}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Xdebug extension helps you debugging your script by providing a
29 lot of valuable debug information. The debug information that Xdebug
30 can provide includes the following:
31
32 - stack and function traces in error messages with:
33  - full parameter display for user defined functions
34  - function name, file name and line indications
35  - support for member functions memory allocation
36 - protection for infinite recursions
37
38 Xdebug also provides:
39
40 - profiling information for PHP scripts
41 - script execution analysis
42 - capabilities to debug your scripts interactively with a debug client
43
44 In PECL status of this package is: %{_status}.
45
46 %description -l pl
47 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczaj±c
48 du¿o warto¶ciowych informacji. Informacje przydatne do ¶ledzenia,
49 które mo¿e zapewniæ Xdebug, obejmuj±:
50
51 - ¶ledzenie stosu i funkcji w komunikatach b³êdów wraz z:
52  - pe³nym wy¶wietlaniem parametrów dla funkcji zdefiniowanych przez
53    u¿ytkownika
54  - nazwami funkcji, nazwami plików i numerami linii
55  - obs³ug± metod klas
56 - przydzielanie pamiêci
57 - zabezpieczenie przed nieskoñczon± rekurencj±
58
59 Xdebug dostarcza tak¿e:
60
61 - informacje do profilowania skryptów PHP
62 - analizê wywo³añ skryptu
63 - mo¿liwo¶æ ¶ledzenia skryptów interaktywnie przy pomocy klienta
64   odpluskwiacza
65
66 To rozszerzenie ma w PECL status: %{_status}.
67
68 %prep
69 %setup -q -c
70
71 %build
72 cd %{_modname}-%{version}%{_snap}
73 phpize
74 %configure
75 %{__make}
76 cd debugclient
77 install /usr/share/automake/config.* .
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %configure \
82         --with-libedit
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/conf.d,%{extensionsdir}}
88
89 install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
90 install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
91 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
92 ; Enable %{_modname} extension module
93 zend_extension_ts=%{extensionsdir}/%{_modname}.so
94 EOF
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
101 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
102
103 %postun
104 if [ "$1" = 0 ]; then
105         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
106         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc %{_modname}-*/{README,NEWS,Changelog,CREDITS}
112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
113 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
114 %attr(755,root,root) %{_bindir}/*
This page took 0.043313 seconds and 4 git commands to generate.