]> git.pld-linux.org Git - packages/php-pecl-tcpwrap.git/blob - php-pecl-tcpwrap.spec
- added some BR:
[packages/php-pecl-tcpwrap.git] / php-pecl-tcpwrap.spec
1 %define         _modname        tcpwrap
2 %define         _status         stable
3 Summary:        %{_modname} - tcpwrapper bindings
4 Summary(pl):    %{_modname} - dowi±zania tcpwrapper
5 Name:           php-pecl-%{_modname}
6 Version:        0.1
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  bbdae2bbea97ae00134550fafed9f76e
12 URL:            http://pecl.php.net/package/tcpwrap/
13 BuildRequires:  libtool
14 BuildRequires:  libwrap-devel
15 BuildRequires:  php-devel
16 Requires:       php-common
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 This package handles /etc/hosts.allow and /etc/hosts.deny files.
25
26 This extension has in PEAR status: %{_status}.
27
28 %description -l pl
29 Za pomoc± tego pakietu mo¿liwa jest obs³uga plików /etc/hosts.allow oraz
30 /etc/hosts.deny.
31
32 To rozszerzenie ma w PEAR status: %{_status}.
33
34 %prep
35 %setup -q -c
36
37 %build
38 cd %{_modname}-%{version}
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{extensionsdir}
46
47 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
54
55 %preun
56 if [ "$1" = "0" ]; then
57         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
58 fi
59
60 %files
61 %defattr(644,root,root,755)
62 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
63 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.112044 seconds and 4 git commands to generate.