]> git.pld-linux.org Git - packages/php-pecl-tcpwrap.git/blob - php-pecl-tcpwrap.spec
add branch.diff, fixes build on php 5.5
[packages/php-pecl-tcpwrap.git] / php-pecl-tcpwrap.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname tcpwrap
3 %define         status          stable
4 Summary:        %{modname} - tcpwrapper bindings
5 Summary(pl.UTF-8):      %{modname} - dowiązania tcpwrapper
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.1.3
8 Release:        9
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  6db26ebbf6c59fedf2228e662fe78e3e
13 Patch0:         branch.diff
14 URL:            http://pecl.php.net/package/tcpwrap/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.4
16 BuildRequires:  libwrap-devel
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-pecl-tcpwrap < 1.1.3-7
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package handles /etc/hosts.allow and /etc/hosts.deny files.
25
26 In PECL status of this package is: %{status}.
27
28 %description -l pl.UTF-8
29 Za pomocą tego pakietu możliwa jest obsługa plików /etc/hosts.allow
30 oraz /etc/hosts.deny.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37 %patch0 -p0
38
39 %build
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
47 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49 ; Enable %{modname} extension module
50 extension=%{modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CREDITS EXPERIMENTAL
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.414319 seconds and 3 git commands to generate.