]> git.pld-linux.org Git - packages/php-pecl-tcpwrap.git/blob - php-pecl-tcpwrap.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-tcpwrap.git] / php-pecl-tcpwrap.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname tcpwrap
3 %define         status          stable
4 Summary:        %{modname} - tcpwrapper bindings
5 Summary(pl.UTF-8):      %{modname} - dowiązania tcpwrapper
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.1.3
8 Release:        6
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  6db26ebbf6c59fedf2228e662fe78e3e
13 URL:            http://pecl.php.net/package/tcpwrap/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  libwrap-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-pear-%{modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package handles /etc/hosts.allow and /etc/hosts.deny files.
25
26 In PECL status of this package is: %{status}.
27
28 %description -l pl.UTF-8
29 Za pomocą tego pakietu możliwa jest obsługa plików /etc/hosts.allow
30 oraz /etc/hosts.deny.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS EXPERIMENTAL
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.053948 seconds and 3 git commands to generate.