]> git.pld-linux.org Git - packages/php-pecl-tcpwrap.git/blob - php-pecl-tcpwrap.spec
00ce2a498f8704b5ce3e796e3f97a45eb71275e3
[packages/php-pecl-tcpwrap.git] / php-pecl-tcpwrap.spec
1 %define         _modname        tcpwrap
2 %define         _status         stable
3 Summary:        %{_modname} - tcpwrapper bindings
4 Summary(pl):    %{_modname} - dowi±zania tcpwrapper
5 Name:           php-pecl-%{_modname}
6 Version:        1.0
7 Release:        2
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  ed68d289c6ce0155b2bd6e62b6ed0996
12 URL:            http://pecl.php.net/package/tcpwrap/
13 BuildRequires:  libwrap-devel
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 Obsoletes:      php-pear-%{_modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This package handles /etc/hosts.allow and /etc/hosts.deny files.
23
24 In PECL status of this package is: %{_status}.
25
26 %description -l pl
27 Za pomoc± tego pakietu mo¿liwa jest obs³uga plików /etc/hosts.allow
28 oraz /etc/hosts.deny.
29
30 To rozszerzenie ma w PECL status: %{_status}.
31
32 %prep
33 %setup -q -c
34
35 %build
36 cd %{_modname}-%{version}
37 phpize
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
44
45 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
46 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
47 ; Enable %{_modname} extension module
48 extension=%{_modname}.so
49 EOF
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %php_webserver_restart
56
57 %postun
58 if [ "$1" = 0 ]; then
59         %php_webserver_restart
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
65 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
66 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.311057 seconds and 2 git commands to generate.