]> git.pld-linux.org Git - packages/php-pecl-statgrab.git/blob - php-pecl-statgrab.spec
- initial import
[packages/php-pecl-statgrab.git] / php-pecl-statgrab.spec
1 %define         _modname        statgrab
2 %define         _smodname       Statgrab
3 %define         _status         beta
4
5 Summary:        %{_modname} - libstatgrab bindings
6 Summary(pl):    %{_modname} - dowi±zania biblioteki libstatgrab
7 Name:           php-pecl-%{_modname}
8 Version:        0.1
9 Release:        1
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  76552f59bf166ebf06862fa10885d984
14 URL:            http://pecl.php.net/package/statgrab/
15 BuildRequires:  libtool
16 BuildRequires:  php-devel
17 Requires:       php-common
18 Obsoletes:      php-pear-%{_modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sysconfdir     /etc/php
22 %define         extensionsdir   %{_libdir}/php
23
24 %description
25 libstatgrab is a library that provides a common interface for retrieving a
26 variety of system statistics on a number of *NIX like systems.
27
28 This extension allows you to call the functions made available by libstatgrab
29 library. 
30
31 This extension has in PEAR status: %{_status}.
32
33 %description -l pl
34
35 To rozszerzenie ma w PEAR status: %{_status}.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_smodname}-%{version}
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{extensionsdir}
49
50 install %{_smodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc %{_smodname}-%{version}/CREDITS
66 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.062964 seconds and 4 git commands to generate.