]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
feba7aef8047b4e8c7f4a756b165cf8665ca66ec
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         _modname        ssh2
2 %define         _status         beta
3 Summary:        %{_modname} - bindings for the libssh2 library
4 Summary(pl):    %{_modname} - dowi±zania do biblioteki libssh2
5 Name:           php-pecl-%{_modname}
6 Version:        0.10
7 Release:        1
8 License:        PHP
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  95bdbd6a9a0d14cb65c6d6bdc9ee1770
12 URL:            http://pecl.php.net/package/ssh2/
13 BuildRequires:  libssh2-devel >= 0.5
14 BuildRequires:  openssl-devel >= 0.9.7d
15 BuildRequires:  php-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 %{?requires_php_extension}
18 Requires:       php-common >= 4:5.0.4
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Provides bindings to the functions of libssh2 which implements the
24 SSH2 protocol.
25
26 In PECL status of this extension is: %{_status}.
27
28 %description -l pl
29 Dostarcza dowi±zañ do ró¿nych funkcji biblioteki libssh2
30 implementuj±cej protokó³ SSH2.
31
32 To rozszerzenie ma w PECL status: %{_status}.
33
34 %prep
35 %setup -q -c
36
37 %build
38 cd %{_modname}-%{version}
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46
47 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49 ; Enable %{_modname} extension module
50 extension=%{_modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.117609 seconds and 2 git commands to generate.