]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
3330dbfe85559113f865255499e8a6dafe036dff
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname ssh2
3 %define         status  beta
4 Summary:        %{modname} - bindings for the libssh2 library
5 Summary(pl.UTF-8):      %{modname} - dowiązania do biblioteki libssh2
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.11.0
8 Release:        5
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  9f5dcd5b92299458389038f7318cbc46
13 Patch0:         php-pecl-ssh2-libssh2.patch
14 Patch1:         branch.diff
15 URL:            http://pecl.php.net/package/ssh2/
16 BuildRequires:  libssh2-devel >= 0.16
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRequires:  %{php_name}-devel >= 4:5.0.4
19 BuildRequires:  rpmbuild(macros) >= 1.650
20 %{?requires_php_extension}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides bindings to the functions of libssh2 which implements the
25 SSH2 protocol.
26
27 In PECL status of this extension is: %{status}.
28
29 %description -l pl.UTF-8
30 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
31 implementującej protokół SSH2.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38 %patch0 -p0
39 %patch1 -p0
40
41 %build
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
49 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
50 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
51 ; Enable %{modname} extension module
52 extension=%{modname}.so
53 EOF
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.069778 seconds and 2 git commands to generate.