]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blame_incremental - php-pecl-ssh2.spec
use 00 prefix for extname
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
... / ...
CommitLineData
1%define php_name php%{?php_suffix}
2%define modname ssh2
3Summary: %{modname} - bindings for the libssh2 library
4Summary(pl.UTF-8): %{modname} - dowiązania do biblioteki libssh2
5Name: %{php_name}-pecl-%{modname}
6Version: 1.1.2
7Release: 1
8License: PHP
9Group: Development/Languages/PHP
10Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
11# Source0-md5: 0bb1b02ae6d1d1a86134959e9b45ae69
12URL: https://pecl.php.net/package/ssh2
13BuildRequires: %{php_name}-devel >= 4:5.0.4
14BuildRequires: libssh2-devel >= 1.2.9
15BuildRequires: openssl-devel >= 0.9.7d
16BuildRequires: rpmbuild(macros) >= 1.650
17%{?requires_php_extension}
18Provides: php(%{modname}) = %{version}
19Obsoletes: php-pecl-ssh2 < 0.12-4
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Provides bindings to the functions of libssh2 which implements the
24SSH2 protocol.
25
26%description -l pl.UTF-8
27Dostarcza dowiązań do różnych funkcji biblioteki libssh2
28implementującej protokół SSH2.
29
30%prep
31%setup -qc
32mv %{modname}-%{version}/* .
33
34%build
35phpize
36%configure
37%{__make}
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
42install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
43cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/00_%{modname}.ini
44; Enable %{modname} extension module
45extension=%{modname}.so
46EOF
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52%php_webserver_restart
53
54%postun
55if [ "$1" = 0 ]; then
56 %php_webserver_restart
57fi
58
59%files
60%defattr(644,root,root,755)
61%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*_%{modname}.ini
62%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.099449 seconds and 4 git commands to generate.