]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blame - php-pecl-ssh2.spec
fix bug #73524: segfault in scandir over ssh2
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
CommitLineData
47fc9518 1%define php_name php%{?php_suffix}
0f92866c 2%define modname ssh2
0f92866c
ER
3Summary: %{modname} - bindings for the libssh2 library
4Summary(pl.UTF-8): %{modname} - dowiązania do biblioteki libssh2
47fc9518 5Name: %{php_name}-pecl-%{modname}
c179bae3
ER
6Version: 0.13
7Release: 1
2903db35 8License: PHP
45ecaa2e 9Group: Development/Languages/PHP
0f92866c 10Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
c179bae3 11# Source0-md5: e35f8438b3f6177066166c8c1916f44e
7969f0ad 12Patch0: bug-73524.patch
c179bae3 13URL: https://pecl.php.net/package/ssh2
2db4ed43 14BuildRequires: %{php_name}-devel >= 4:5.0.4
8fae05b2 15BuildRequires: libssh2-devel >= 1.2.9
2903db35 16BuildRequires: openssl-devel >= 0.9.7d
47fc9518 17BuildRequires: rpmbuild(macros) >= 1.650
5486253a 18%{?requires_php_extension}
2db4ed43 19Provides: php(%{modname}) = %{version}
fd4940c0 20Obsoletes: php-pecl-ssh2 < 0.12-4
45ecaa2e
AG
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
45ecaa2e
AG
23%description
24Provides bindings to the functions of libssh2 which implements the
25SSH2 protocol.
26
0313d4ea
JR
27%description -l pl.UTF-8
28Dostarcza dowiązań do różnych funkcji biblioteki libssh2
29implementującej protokół SSH2.
45ecaa2e 30
45ecaa2e 31%prep
0f92866c
ER
32%setup -qc
33mv %{modname}-%{version}/* .
7969f0ad 34%patch0 -p1
45ecaa2e
AG
35
36%build
45ecaa2e
AG
37phpize
38%configure
39%{__make}
40
41%install
42rm -rf $RPM_BUILD_ROOT
890c59dd 43install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
0f92866c
ER
44install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
45cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
46; Enable %{modname} extension module
47extension=%{modname}.so
5486253a 48EOF
45ecaa2e
AG
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
890c59dd 54%php_webserver_restart
45ecaa2e 55
5486253a
ER
56%postun
57if [ "$1" = 0 ]; then
890c59dd 58 %php_webserver_restart
45ecaa2e
AG
59fi
60
61%files
62%defattr(644,root,root,755)
0f92866c
ER
63%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
64%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.139309 seconds and 4 git commands to generate.