]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/commitdiff
fix bug #73524: segfault in scandir over ssh2 auto/th/php-pecl-ssh2-0.13-1
authorElan Ruusamäe <glen@delfi.ee>
Thu, 4 May 2017 13:35:10 +0000 (16:35 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 4 May 2017 13:35:10 +0000 (16:35 +0300)
backport fix from https://bugs.php.net/bug.php?id=73524

Commit in PHP 5 branch:
https://github.com/php/pecl-networking-ssh2/commit/093906ec1c065e86ad1cd4dabbc89b1ccae11938

bug-73524.patch [new file with mode: 0644]
php-pecl-ssh2.spec

diff --git a/bug-73524.patch b/bug-73524.patch
new file mode 100644 (file)
index 0000000..91c9175
--- /dev/null
@@ -0,0 +1,46 @@
+From 093906ec1c065e86ad1cd4dabbc89b1ccae11938 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 10 Nov 2016 09:16:02 +0100
+Subject: [PATCH] fix for PHP 7.0.13 where php_url_parse fails
+
+---
+ ssh2_fopen_wrappers.c | 17 ++++++++++++-----
+ 1 file changed, 12 insertions(+), 5 deletions(-)
+
+diff --git a/ssh2_fopen_wrappers.c b/ssh2_fopen_wrappers.c
+index 8472ddd..89b34eb 100644
+--- a/ssh2_fopen_wrappers.c
++++ b/ssh2_fopen_wrappers.c
+@@ -198,10 +198,20 @@ php_url *php_ssh2_fopen_wraper_parse_path(       char *path, char *type, php_stream_co
+       php_url *resource;
+       zval *methods = NULL, *callbacks = NULL, zsession, **tmpzval;
+       long resource_id;
+-      char *s, *username = NULL, *password = NULL, *pubkey_file = NULL, *privkey_file = NULL;
++      char *h, *s, *username = NULL, *password = NULL, *pubkey_file = NULL, *privkey_file = NULL;
+       int username_len = 0, password_len = 0;
+-      resource = php_url_parse(path);
++      h = strstr(path, "Resource id #");
++      if (h) {
++              /* Starting with 5.6.28, 7.0.13 need to be clean, else php_url_parse will fail */
++              char *tmp = estrdup(path);
++
++              strncpy(tmp + (h-path), h + sizeof("Resource id #")-1, strlen(tmp)-sizeof("Resource id #"));
++              resource = php_url_parse(tmp);
++              efree(tmp);
++      } else {
++              resource = php_url_parse(path);
++      }
+       if (!resource || !resource->path) {
+               return NULL;
+       }
+@@ -232,9 +242,6 @@ php_url *php_ssh2_fopen_wraper_parse_path( char *path, char *type, php_stream_co
+       /* Look for a resource ID to reuse a session */
+       s = resource->host;
+-      if (strncmp(resource->host, "Resource id #", sizeof("Resource id #") - 1) == 0) {
+-              s = resource->host + sizeof("Resource id #") - 1;
+-      }
+       if (is_numeric_string(s, strlen(s), &resource_id, NULL, 0) == IS_LONG) {
+               php_ssh2_sftp_data *sftp_data;
index 4996b8c4a9719f102afbaba09e07da4e0849711a..46d74958a90eca0e21e086acb113c115fa5916e7 100644 (file)
@@ -9,6 +9,7 @@ License:        PHP
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: e35f8438b3f6177066166c8c1916f44e
+Patch0:                bug-73524.patch
 URL:           https://pecl.php.net/package/ssh2
 BuildRequires: %{php_name}-devel >= 4:5.0.4
 BuildRequires: libssh2-devel >= 1.2.9
@@ -30,6 +31,7 @@ implementującej protokół SSH2.
 %prep
 %setup -qc
 mv %{modname}-%{version}/* .
+%patch0 -p1
 
 %build
 phpize
This page took 0.141191 seconds and 4 git commands to generate.