]> git.pld-linux.org Git - packages/php-pecl-session_mysql.git/blob - php-pecl-session_mysql.spec
c9934bfdbecd92bc1ebc85493ff92407e347fa5f
[packages/php-pecl-session_mysql.git] / php-pecl-session_mysql.spec
1 %define         _modname        session_mysql
2 Summary:        MySQL session save handler for PHP
3 Summary(pl.UTF-8):      Obsługa zapisywania sesji w bazie MySQL dla PHP
4 Name:           php-pecl-%{_modname}
5 Version:        1.10
6 Release:        6
7 License:        MIT
8 Group:          Development/Languages/PHP
9 Source0:        http://websupport.sk/~stanojr/projects/session_mysql/%{_modname}-%{version}.tgz
10 # Source0-md5:  66e933c506577ad43a0effbd2bbad715
11 Source1:        %{name}.ini
12 Source2:        %{name}.sql
13 URL:            http://websupport.sk/~stanojr/projects/session_mysql/
14 BuildRequires:  mysql-devel
15 BuildRequires:  php-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 %{?requires_php_extension}
18 Requires:       php-common >= 4:5.0.4
19 Requires:       php-session
20 Provides:       php(session_mysql)
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 MySQL session save handler for PHP.
25
26 %description -l pl.UTF-8
27 Obsługa zapisywania sesji w bazie MySQL dla PHP.
28
29 %prep
30 %setup -q -n %{_modname}-%{version}
31 cp -a %{SOURCE2} database.sql
32
33 %build
34 [ config.m4 -ot configure ] || rm -f configure
35 [ -f configure ] || phpize
36 [ configure -ot Makefile ] || rm -f Makefile
37 if [ ! -f Makefile ]; then
38         %configure \
39         --with-mysql=/usr
40 fi
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46
47 install -p modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %php_webserver_restart
55
56 %postun
57 if [ "$1" = 0 ]; then
58         %php_webserver_restart
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc LICENCE README database.sql
64 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
65 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.036985 seconds and 2 git commands to generate.