]> git.pld-linux.org Git - packages/php-pecl-sasl.git/commitdiff
- conf.d and php api macros
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 14 Sep 2005 13:37:00 +0000 (13:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-pecl-sasl.spec -> 1.10

php-pecl-sasl.spec

index cc4e5bc21c76cbeef6ffca9ff644ef0b88289ecf..8675727d359dba54b504ea5c761809a3fc8f3679 100644 (file)
@@ -1,11 +1,13 @@
 %define                _modname        sasl
 %define                _status         alpha
+%define                _sysconfdir     /etc/php
+%define                extensionsdir   %(php-config --extension-dir 2>/dev/null)
 
 Summary:       %{_modname} - Cyrus SASL extension
 Summary(pl):   %{_modname} - rozszerzenie Cyrus SASL
 Name:          php-pecl-%{_modname}
 Version:       0.1.0
-Release:       2
+Release:       2.1
 License:       PHP 2.02
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
@@ -14,14 +16,13 @@ Patch0:             %{name}-lib_fix.patch
 Patch1:                %{name}-lib64_fix.patch
 URL:           http://pecl.php.net/package/sasl/
 BuildRequires: cyrus-sasl-devel
-BuildRequires: php-devel
-Requires:      php-common
+BuildRequires: php-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.238
+%{?requires_php_extension}
+Requires:      %{_sysconfdir}/conf.d
 Obsoletes:     php-pear-%{_modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %{_libdir}/php
-
 %description
 SASL is the Simple Authentication and Security Layer (as defined by
 RFC 2222). It provides a system for adding plugable authenticating
@@ -64,22 +65,29 @@ phpize
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{extensionsdir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
 
 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
+; Enable %{_modname} extension module
+extension=%{_modname}.so
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
+[ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
+[ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
 
-%preun
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
+%postun
+if [ "$1" = 0 ]; then
+       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
+       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc %{_modname}-%{version}/docs/TODO
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.065108 seconds and 4 git commands to generate.