]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
- more general lib64 if
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         _modname        sasl
2 %define         _status         alpha
3
4 Summary:        %{_modname} - Cyrus SASL extension
5 Summary(pl):    %{_modname} - rozszerzenie Cyrus SASL
6 Name:           php-pecl-%{_modname}
7 Version:        0.1.0
8 Release:        2
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 Patch0:         %{name}-lib_fix.patch
14 Patch1:         %{name}-lib64_fix.patch
15 URL:            http://pecl.php.net/package/sasl/
16 BuildRequires:  cyrus-sasl-devel
17 BuildRequires:  libtool
18 BuildRequires:  php-devel
19 Requires:       php-common
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc/php
24 %define         extensionsdir   %{_libdir}/php
25
26 %description
27 SASL is the Simple Authentication and Security Layer (as defined by
28 RFC 2222). It provides a system for adding plugable authenticating
29 support to connection-based protocols. The SASL extension for PHP
30 makes the Cyrus SASL library functions available to PHP. It aims to
31 provide a 1-to-1 wrapper around the SASL library to provide the
32 greatest amount of implementation flexibility. To that end, it is
33 possible to build both a client-side and server-side SASL
34 implementation entirely in PHP.
35
36 In PECL status of this extension is: %{_status}.
37
38 %description -l pl
39 SASL to warstwa prostego uwierzytelnienia i bezpieczeñstwa (Simple
40 Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
41 system do dodawania wtyczek obs³uguj±cych uwierzytelnianie do
42 protoko³ów opartych na po³±czeniach. Rozszerzenie SASL dla PHP
43 udostêpnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
44 dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostêpniæ jak
45 najwiêksz± elastyczno¶æ implementacji. W tym celu mo¿liwe jest
46 zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
47 ca³kowicie w PHP.
48
49 To rozszerzenie ma w PECL status: %{_status}.
50
51 %prep
52 %setup -q -c
53 # Ugly, could be done somehow prettier (one combined patch?)
54 %if "%{_lib}" == "lib64"
55 %patch1 -p1
56 %else
57 %patch0 -p1
58 %endif
59
60 %build
61 cd %{_modname}-%{version}
62 phpize
63 %configure
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{extensionsdir}
69
70 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
77
78 %preun
79 if [ "$1" = "0" ]; then
80         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
81 fi
82
83 %files
84 %defattr(644,root,root,755)
85 %doc %{_modname}-%{version}/docs/TODO
86 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.204818 seconds and 3 git commands to generate.