]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname sasl
3 %define         status          alpha
4 Summary:        %{modname} - Cyrus SASL extension
5 Summary(pl.UTF-8):      %{modname} - rozszerzenie Cyrus SASL
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.1.0
8 Release:        13
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 Patch0:         php-pecl-%{modname}-lib_fix.patch
14 Patch1:         php-pecl-%{modname}-lib64_fix.patch
15 URL:            http://pecl.php.net/package/sasl/
16 BuildRequires:  %{php_name}-devel >= 3:5.0.0
17 BuildRequires:  cyrus-sasl-devel
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 %{?requires_php_extension}
20 Requires:       php(core) >= 5.0.4
21 Provides:       php(%{modname}) = %{version}
22 Obsoletes:      php-pear-%{modname}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 SASL is the Simple Authentication and Security Layer (as defined by
27 RFC 2222). It provides a system for adding plugable authenticating
28 support to connection-based protocols. The SASL extension for PHP
29 makes the Cyrus SASL library functions available to PHP. It aims to
30 provide a 1-to-1 wrapper around the SASL library to provide the
31 greatest amount of implementation flexibility. To that end, it is
32 possible to build both a client-side and server-side SASL
33 implementation entirely in PHP.
34
35 In PECL status of this extension is: %{status}.
36
37 %description -l pl.UTF-8
38 SASL to warstwa prostego uwierzytelnienia i bezpieczeństwa (Simple
39 Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
40 system do dodawania wtyczek obsługujących uwierzytelnianie do
41 protokołów opartych na połączeniach. Rozszerzenie SASL dla PHP
42 udostępnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
43 dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostępnić jak
44 największą elastyczność implementacji. W tym celu możliwe jest
45 zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
46 całkowicie w PHP.
47
48 To rozszerzenie ma w PECL status: %{status}.
49
50 %prep
51 %setup -qc
52 mv %{modname}-%{version}/* .
53 # Ugly, could be done somehow prettier (one combined patch?)
54 %if "%{_lib}" == "lib64"
55 %patch1 -p2
56 %else
57 %patch0 -p2
58 %endif
59
60 %build
61 phpize
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
68 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
69 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
70 ; Enable %{modname} extension module
71 extension=%{modname}.so
72 EOF
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %php_webserver_restart
79
80 %postun
81 if [ "$1" = 0 ]; then
82         %php_webserver_restart
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc docs/TODO
88 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
89 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.061616 seconds and 3 git commands to generate.