]> git.pld-linux.org Git - packages/php-pecl-rpmreader.git/commitdiff
support building for multiple php versions
authorElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:40 +0000 (20:18 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 21 Jun 2013 17:18:40 +0000 (20:18 +0300)
php-pecl-rpmreader.spec

index 1787d7549ee283ca8977f56c1cd035f31944aad6..35cc172c0fdc29bcd37b91e3d448b5dd7d4e8c22 100644 (file)
@@ -1,17 +1,18 @@
-%define                _modname        rpmreader
-%define                _status         beta
-Summary:       %{_modname} - RPM file meta information reader
-Summary(pl.UTF-8):     %{_modname} - odczyt metainformacji z plików RPM
-Name:          php-pecl-%{_modname}
+%define                php_name        php%{?php_suffix}
+%define                modname rpmreader
+%define                status          beta
+Summary:       %{modname} - RPM file meta information reader
+Summary(pl.UTF-8):     %{modname} - odczyt metainformacji z plików RPM
+Name:          %{php_name}-pecl-%{modname}
 Version:       0.3
 Release:       4
 License:       PHP 3.0
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 73aca25e6f5b7b17dffe4dfb63110505
 URL:           http://pecl.php.net/package/rpmreader/
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: %{php_name}-devel >= 3:5.0.0
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
 Requires:      php-common >= 4:5.0.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -22,7 +23,7 @@ Package Manager (RPM) files' header information. This extension
 currently does not provide the functionality to read the signature or
 archive sections of the RPM file.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 rpmreader jest rozszerzeniem umożliwiającym odczyt informacji z
@@ -30,13 +31,13 @@ nagłówków plików RPM (RPM Package Manager). Rozszerzenie to na chwilę
 obecną nie udostępnia możliwości odczytu podpisu ani zawartości
 archiwum pliku RPM.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -45,10 +46,10 @@ phpize
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -64,6 +65,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{CREDITS,examples}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc CREDITS examples
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.0447 seconds and 4 git commands to generate.