]> git.pld-linux.org Git - packages/php-pecl-python.git/blob - php-pecl-python.spec
- fixed english information about status of the package (also s/PEAR/PECL/)
[packages/php-pecl-python.git] / php-pecl-python.spec
1 %define         _modname                python
2 %define         _status                 alpha
3 Summary:        Embedded Python
4 Summary(pl):    Python wbudowany w PHP
5 Name:           php-pecl-%{_modname}
6 Version:        0.7.0
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  61554c04374a5fab83084e299284f255
12 URL:            http://pecl.php.net/package/python/
13 BuildRequires:  automake
14 BuildRequires:  php-devel
15 BuildRequires:  python-devel
16 Requires:       php-common
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _sysconfdir     /etc/php
20 %define         extensionsdir   %{_libdir}/php
21
22 %description
23 This extension allows the Python interpreter to be embedded inside of
24 PHP, allowing for the instantiate and manipulation of Python objects
25 from within PHP.
26
27 In PECL status of this package is: %{_status}.
28
29 %description -l pl
30 To rozszerzenie pozwala na wbudowanie interpretera Pythona do PHP, co
31 pozwala na wykorzystanie i manipulowanie obiektami Pythona z wewn±trz
32 PHP.
33
34 To rozszerzenie ma w PECL status: %{_status}.
35
36 %prep
37 %setup -q -c
38
39 %build
40 cd %{_modname}-%{version}
41 phpize
42 %{__aclocal}
43 %configure \
44         --with-%{_modname}
45
46 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11/"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{extensionsdir}
51
52 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 /usr/sbin/php-module-install install %{_modname} %{_sysconfdir}/php.ini
59
60 %preun
61 if [ "$1" = "0" ]; then
62         /usr/sbin/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
68 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.073187 seconds and 4 git commands to generate.