]> git.pld-linux.org Git - packages/php-pecl-python.git/blob - php-pecl-python.spec
- pl description
[packages/php-pecl-python.git] / php-pecl-python.spec
1 %define         _modname                python
2 Summary:        Embedded Python
3 Summary(pl):    Python wbudowany w PHP
4 Name:           php-pecl-%{_modname}
5 Version:        0.6.0
6 Release:        1
7 License:        PHP 2.02
8 Group:          Development/Languages/PHP
9 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
10 URL:            http://pear.php.net/
11 BuildRequires:  automake
12 BuildRequires:  php-devel
13 BuildRequires:  python-devel
14 Requires:       php-common
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sysconfdir     /etc/php
18 %define         extensionsdir   %{_libdir}/php
19
20 %description
21 This extension allows the Python interpreter to be embedded inside of
22 PHP, allowing for the instantiate and manipulation of Python objects
23 from within PHP.
24
25 %description -l pl
26 To rozszerzenie pozwala na wbudowanie interpretera Pythona do PHP, co
27 pozwala na wykorzystanie i manipulowanie obiektami Pythona z wewn±trz
28 PHP.
29
30 %prep
31 %setup -q -c
32
33 %build
34 cd %{_modname}-%{version}
35 phpize
36 %{__aclocal}
37 %configure \
38         --with-%{_modname}
39
40 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11/"
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{extensionsdir}
45
46 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 /usr/sbin/php-module-install install %{_modname} %{_sysconfdir}/php.ini
53
54 %preun
55 if [ "$1" = "0" ]; then
56         /usr/sbin/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
62 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.136224 seconds and 4 git commands to generate.