]> git.pld-linux.org Git - packages/php-pecl-ps.git/blob - php-pecl-ps.spec
6d0ad8148762bfd126471ad2832a74a6d54823dd
[packages/php-pecl-ps.git] / php-pecl-ps.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname ps
3 %define         status  stable
4 Summary:        %{modname} - an extension to create PostScript files
5 Summary(pl.UTF-8):      %{modname} - rozszerzenie do tworzenia plików PostScript
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.3.6
8 Release:        7
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  256c5cc3877b03b67963896b84fef306
13 URL:            http://pecl.php.net/package/ps/
14 BuildRequires:  %{php_name}-devel >= 4:5.0.4
15 BuildRequires:  pslib-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 ps is an extension similar to the pdf extension but for creating
22 PostScript files. Its API is modelled after the pdf extension.
23
24 In PECL status of this package is: %{status}.
25
26 %description -l pl.UTF-8
27 ps jest rozszerzeniem podobnym do pdf ale służącym do tworzenia plików
28 PostScript. API jest wzorowane na rozszerzeniu pdf.
29
30 To rozszerzenie ma w PECL status: %{status}.
31
32 %prep
33 %setup -qc
34 mv %{modname}-%{version}/* .
35
36 %build
37 phpize
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
44
45 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
46 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
47 ; Enable %{modname} extension module
48 extension=%{modname}.so
49 EOF
50
51 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CREDITS
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
69 %{_examplesdir}/%{name}-%{version}
This page took 0.059566 seconds and 2 git commands to generate.