]> git.pld-linux.org Git - packages/php-pecl-protobuf.git/commitdiff
Initial auto/th/php-pecl-protobuf-3.22.5-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 16 May 2023 09:07:09 +0000 (11:07 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 16 May 2023 09:07:09 +0000 (11:07 +0200)
php-pecl-protobuf.spec [new file with mode: 0644]

diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
new file mode 100644 (file)
index 0000000..e9cd27c
--- /dev/null
@@ -0,0 +1,78 @@
+# Conditional build:
+%bcond_without tests           # build without tests
+
+%define                php_name        php%{?php_suffix}
+%define                modname protobuf
+Summary:       Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data
+Name:          %{php_name}-pecl-%{modname}
+Version:       3.22.5
+Release:       1
+License:       BSD
+Group:         Development/Languages/PHP
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
+# Source0-md5: 4bac21850c210567048780a625d32b26
+URL:           http://pecl.php.net/package/protobuf/
+%{?with_tests:BuildRequires:    %{php_name}-cli}
+BuildRequires: %{php_name}-devel >= 4:5.5
+BuildRequires: protobuf-devel
+BuildRequires: rpmbuild(macros) >= 1.666
+%if %{with tests}
+%endif
+%{?requires_php_extension}
+Provides:      php(protobuf) = %{version}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Protocol Buffers are a language-neutral, platform-neutral extensible
+mechanism for serializing structured data.
+
+%prep
+%setup -qc
+mv %{modname}-%{version}/* .
+
+%build
+phpize
+%configure
+%{__make}
+
+%if %{with tests}
+# simple module load test
+%{__php} -n -q \
+       -d extension_dir=modules \
+       -d extension=%{modname}.so \
+       -m > modules.log
+grep %{modname} modules.log
+
+export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+%{__make} test \
+       PHP_EXECUTABLE=%{__php} \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl"
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       EXTENSION_DIR=%{php_extensiondir} \
+       INSTALL_ROOT=$RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
+EOF
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%php_webserver_restart
+
+%postun
+if [ "$1" = 0 ]; then
+       %php_webserver_restart
+fi
+
+%files
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.152135 seconds and 4 git commands to generate.