]> git.pld-linux.org Git - packages/php-pecl-pdflib.git/blob - php-pecl-pdflib.spec
- tabs in preamble
[packages/php-pecl-pdflib.git] / php-pecl-pdflib.spec
1 %define         _modname        pdflib
2 %define         _smodname       pdf
3 %define         _status         stable
4 Summary:        %{_modname} - creating PDF on the fly with the PDFlib library
5 Summary(pl.UTF-8):      %{_modname} - tworzenie PDF "w locie" za pomocą biblioteki PDFlib
6 Name:           php-pecl-%{_modname}
7 Version:        1.0
8 Release:        2
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  60341f1afd61a6ec01790793473a702a
13 Patch0:         %{name}-fix_includes.patch
14 URL:            http://pecl.php.net/package/Modname/
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  libpng-devel
17 BuildRequires:  libtiff-devel
18 BuildRequires:  pdflib-devel
19 BuildRequires:  php-devel >= 3:5.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.344
21 BuildRequires:  zlib-devel
22 %{?requires_php_extension}
23 Requires:       php-common >= 4:5.0.4
24 Obsoletes:      php-pear-%{_modname}
25 Obsoletes:      php-pdf < 3:5.0.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This extension wraps the PDFlib programming library for processing PDF
30 on the fly.
31
32 In PECL status of this extension is: %{_status}.
33
34 %description -l pl.UTF-8
35 To rozszerzenie "owija" bibliotekę PDFlib przeznaczoną do tworzenia
36 dokumentów PDF "w locie".
37
38 To rozszerzenie ma w PECL status: %{_status}.
39
40 %prep
41 %setup -q -c
42 %patch0 -p1
43
44 %build
45 cd %{_modname}-%{version}
46 phpize
47 %configure \
48         --with-png-dir=%{_prefix} \
49         --with-jpeg-dir=%{_prefix} \
50         --with-tiff-dir=%{_prefix} \
51         --with-zlib-dir=%{_prefix}
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
57
58 install %{_modname}-%{version}/modules/%{_smodname}.so $RPM_BUILD_ROOT%{php_extensiondir}
59 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
60 ; Enable %{_modname} extension module
61 extension=%{_smodname}.so
62 EOF
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %php_webserver_restart
69
70 %postun
71 if [ "$1" = 0 ]; then
72         %php_webserver_restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc %{_modname}-%{version}/CREDITS
78 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
79 %attr(755,root,root) %{php_extensiondir}/%{_smodname}.so
This page took 0.052805 seconds and 3 git commands to generate.