]> git.pld-linux.org Git - packages/php-pecl-paradox.git/blob - php-pecl-paradox.spec
support building for multiple php versions
[packages/php-pecl-paradox.git] / php-pecl-paradox.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname paradox
3 %define         status          stable
4 Summary:        read and write Paradox files
5 Summary(pl.UTF-8):      odczyt i zapis z/do plików Paradox
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.4.3
8 Release:        5
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  aab0bc4146bc2852a9623b635fa20c17
13 URL:            http://pecl.php.net/package/Paradox/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  pxlib-devel >= 0.6.0
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Paradox is an extension to read and write Paradox .DB and .PX files.
23 It can handle almost all field types and binary large objects stored
24 in .MB files.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 Paradox to rozszerzenie pozwalające na dostęp w trybie odczyt/zapis do
30 plików .DB oraz .PX bazy Paradox. Rozszerzenie pozwala na obsługę
31 prawie wszystkich typów pól i dużych obiektów binarnych (ang. binary
32 large objects, blob) przechowywanych w plikach .MB.
33
34 To rozszerzenie ma w PECL status: %{status}.
35
36 %prep
37 %setup -q -c
38 mv %{modname}-%{version}/* .
39
40 %build
41 phpize
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
48
49 %{__make} install \
50         INSTALL_ROOT=$RPM_BUILD_ROOT \
51         EXTENSION_DIR=%{php_extensiondir}
52 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
53 ; Enable %{modname} extension module
54 extension=%{modname}.so
55 EOF
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %php_webserver_restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         %php_webserver_restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CREDITS
71 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
72 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.063245 seconds and 3 git commands to generate.