]> git.pld-linux.org Git - packages/php-pecl-odbtp.git/blob - php-pecl-odbtp.spec
d411825f1bb5358cf3dbf16e59f8871a212708b5
[packages/php-pecl-odbtp.git] / php-pecl-odbtp.spec
1 %define         _modname        odbtp
2 %define         _status         stable
3
4 Summary:        %{_modname} - ODBTP client functions
5 Summary(pl):    %{_modname} - funkcjonalno¶æ klienta ODBTP
6 Name:           php-pecl-%{_modname}
7 Version:        1.1.2
8 Release:        1
9 License:        LGPL
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  28c3076fefccdca9e07548b8291d41b4
13 Patch0:         %{name}-shared.patch
14 URL:            http://pecl.php.net/package/odbtp/
15 BuildRequires:  libtool
16 BuildRequires:  odbtp-devel
17 BuildRequires:  php-devel
18 Requires:       php-common
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/php
23 %define         extensionsdir   %{_libdir}/php
24
25 %description
26 This extension provides a set of ODBTP, Open Database Transport
27 Protocol, client functions. ODBTP allows any platform to remotely use
28 the ODBC facilities installed on a Win32 host to connect to a
29 database. Linux and UNIX clients can use this extension to access
30 Win32 databases like MS SQL Server, MS Access and Visual FoxPro.
31
32 In PECL status of this extension is: %{_status}.
33
34 %description -l pl
35 To rozszerzenie dostarcza zestaw funkcji klienta ODBTP, Otwartego
36 Protoko³u Transportu Baz Danych (Open Database Transport Protocol).
37 ODBTP pozwala na zdalny dostêp do ODBC zainstalowanego na komputerze 
38 z systemem Windows. Umo¿liwia to dostêp do baz danych takich jak MS 
39 SQL Server, MS Access czy Visual FoxPro z poziomu systemu Linux/Unix.
40
41 To rozszerzenie ma w PECL status: %{_status}.
42
43 %prep
44 %setup -q -c
45 %patch0 -p1
46
47 %build
48 cd %{_modname}-%{version}
49 phpize
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{extensionsdir}
56
57 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
64
65 %preun
66 if [ "$1" = "0" ]; then
67         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
73 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.082541 seconds and 2 git commands to generate.