]> git.pld-linux.org Git - packages/php-pecl-msession.git/blob - php-pecl-msession.spec
- license fixes Andrzej Mateja <amateja () pimpek.one.pl>
[packages/php-pecl-msession.git] / php-pecl-msession.spec
1 # NOTE:
2 # there's no maintainer for the pecl project, so consider this
3 # extension dead.
4 %define         _modname        msession
5 %define         _status         stable
6 Summary:        %{_modname} - extension module for PHP
7 Summary(pl.UTF-8):      %{_modname} - moduł msession dla PHP
8 Name:           php-pecl-%{_modname}
9 Version:        1.0
10 Release:        3
11 License:        PHP 3.01
12 Group:          Development/Languages/PHP
13 # extracted from php-5.1.2 sources as pecl/msession appears to be older
14 Source0:        %{_modname}.tar.bz2
15 # Source0-md5:  a256f635be818a7247d7be15061256f0
16 Patch0:         msession-shared-lib.patch
17 URL:            http://pecl.php.net/package/msession/
18 BuildRequires:  phoenix-devel
19 BuildRequires:  php-devel >= 3:5.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.344
21 %{?requires_php_extension}
22 Requires:       php-common >= 4:5.0.4
23 Provides:       php(msession)
24 Obsoletes:      php-msession
25 ExclusiveArch:  %{ix86}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 msession is a high speed session daemon which can run either locally
30 or remotely. It is designed to provide consistent session management
31 for a PHP web farm.
32
33 In PECL status of this extension is: %{_status}.
34
35 %description -l pl.UTF-8
36 Moduł PHP dodający umożliwiający korzystanie z demona msession. Jest
37 to demon szybkiej obsługi sesji, który może działać lokalnie lub na
38 innej maszynie. Służy do zapewniania spójnej obsługi sesji dla farmy
39 serwerów.
40
41 To rozszerzenie ma w PECL status: %{_status}.
42
43 %prep
44 %setup -q -n %{_modname}
45 %patch0 -p3
46
47 %build
48 phpize
49 %configure \
50         --with-msession=shared,/usr
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
56
57 install modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
58 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
59 ; Enable %{_modname} extension module
60 extension=%{_modname}.so
61 EOF
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %php_webserver_restart
68
69 %postun
70 if [ "$1" = 0 ]; then
71         %php_webserver_restart
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
77 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.063791 seconds and 3 git commands to generate.