]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blob - php-pecl-mongodb.spec
version .ini file separately
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname mongodb
7 Summary:        MongoDB driver for PHP
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        1.2.11
10 Release:        1
11 License:        Apache v2.0
12 Group:          Development/Languages/PHP
13 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
14 # Source0-md5:  c3b36a24b7e47e3b4148cd9bc4d163b2
15 Source1:        mongodb.ini
16 URL:            https://pecl.php.net/package/mongodb
17 BuildRequires:  %{php_name}-devel >= 4:5.4.0
18 BuildRequires:  rpmbuild(macros) >= 1.666
19 %if %{with tests}
20 BuildRequires:  %{php_name}-json
21 BuildRequires:  %{php_name}-spl
22 %endif
23 BuildRequires:  cyrus-sasl-devel
24 BuildRequires:  libbson-devel >= 1.5
25 BuildRequires:  mongo-c-driver-devel >= 1.5
26 BuildRequires:  openssl-devel
27 Requires:       %{php_name}-json
28 %{?requires_php_extension}
29 Provides:       php(%{modname}) = %{version}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The purpose of this driver is to provide exceptionally thin glue
34 between MongoDB and PHP, implementing only fundemental and
35 performance-critical components necessary to build a fully-functional
36 MongoDB driver.
37
38 %prep
39 %setup -qc
40 mv %{modname}-%{version}/* .
41
42 %build
43 # Sanity check, really often broken
44 extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
45 if test "x${extver}" != "x%{version}"; then
46         : Error: Upstream extension version is ${extver}, expecting %{version}.
47         exit 1
48 fi
49
50 phpize
51 # Ensure we use system library
52 # Need to be removed only after phpize because of m4_include
53 %{__rm} -r src/libbson
54 %{__rm} -r src/libmongoc
55
56 %configure \
57         --with-libbson \
58         --with-libmongoc \
59         --enable-mongodb
60
61 %{__make}
62
63 # simple module load test, always enabled
64 %{__php} -n -q \
65         -d extension_dir=modules \
66         -d extension=%{php_extensiondir}/json.so \
67         -d extension=%{php_extensiondir}/spl.so \
68         -d extension=%{modname}.so \
69         -m > modules.log
70 grep %{modname} modules.log
71
72 %if %{with tests}
73 cat <<'EOF' > run-tests.sh
74 #!/bin/sh
75 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
76 exec %{__make} test \
77         PHP_EXECUTABLE=%{__php} \
78         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="json spl" \
79         RUN_TESTS_SETTINGS="-q $*"
80 EOF
81 chmod +x run-tests.sh
82
83 ./run-tests.sh
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} install \
89         EXTENSION_DIR=%{php_extensiondir} \
90         INSTALL_ROOT=$RPM_BUILD_ROOT
91
92 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
93 cp -p %{SOURCE1}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
101 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.072265 seconds and 4 git commands to generate.