]> git.pld-linux.org Git - packages/php-pecl-mongodb.git/blob - php-pecl-mongodb.spec
911fe3dee80d6c7ae159adfe0916e0a423a0cd0a
[packages/php-pecl-mongodb.git] / php-pecl-mongodb.spec
1 # TODO
2 # - ix86/x32 (php -m) prints::
3 #   src/mongoc/mongoc-handshake.c:478 _append_and_truncate(): precondition failed: space_for_suffix >= 0
4 #   Aborted
5 #
6 # Conditional build:
7 %bcond_without  tests           # build without tests
8 %bcond_with     sasl            # Include Cyrus SASL support (for bundled only)
9 %bcond_without  ssl             # Enable TLS connections and SCRAM-SHA-1 authentication (for bundled only)
10 %bcond_with     bundled         # Use bundled libmongoc
11
12 %define         php_name        php%{?php_suffix}
13 %define         modname mongodb
14 Summary:        MongoDB driver for PHP
15 Name:           %{php_name}-pecl-%{modname}
16 Version:        1.5.2
17 Release:        1
18 License:        Apache v2.0
19 Group:          Development/Languages/PHP
20 Source0:        https://pecl.php.net/get/%{modname}-%{version}.tgz
21 # Source0-md5:  3569a12839c9908a25dac15df1ae9d18
22 Source1:        mongodb.ini
23 URL:            https://pecl.php.net/package/mongodb
24 BuildRequires:  %{php_name}-cli
25 BuildRequires:  %{php_name}-devel >= 4:5.5.0
26 BuildRequires:  %{php_name}-json
27 BuildRequires:  %{php_name}-pcre
28 BuildRequires:  %{php_name}-spl
29 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
30 %if %{without bundled}
31 BuildRequires:  libbson-devel >= 1.11.0
32 BuildRequires:  mongo-c-driver-devel >= 1.9
33 %endif
34 BuildRequires:  openssl-devel
35 BuildRequires:  rpmbuild(macros) >= 1.666
36 Requires:       %{php_name}-json
37 Requires:       mongo-c-driver-libs >= 1.9.3-2
38 Requires:       %{php_name}-pcre
39 Requires:       %{php_name}-spl
40 %{?requires_php_extension}
41 Provides:       php(%{modname}) = %{version}
42 ExcludeArch:    %{ix86} x32
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The purpose of this driver is to provide exceptionally thin glue
47 between MongoDB and PHP, implementing only fundemental and
48 performance-critical components necessary to build a fully-functional
49 MongoDB driver.
50
51 %prep
52 %setup -qc
53 mv %{modname}-%{version}/* .
54
55 %if %{without bundled}
56 # Ensure we use system library
57 # remove only C sources, m4 resources needed for phpize via m4_include
58 find \
59         src/libmongoc \
60         -name '*.[ch]' -delete
61 %endif
62
63 xfail() {
64         local t=$1
65         test -f $t
66         cat >> $t <<-EOF
67
68         --XFAIL--
69         Skip
70         EOF
71 }
72
73 # failed tests. investigate later
74 while read line; do
75         t=${line##*\[}; t=${t%\]}
76         xfail $t
77 done << 'EOF'
78 MongoDB\BSON\Javascript::__set_state() [tests/bson/bson-javascript-set_state-001.phpt]
79 MongoDB\Driver\Exception\RuntimeException::hasErrorLabel() [tests/exception/runtimeexception-haserrorlabel-002.phpt]
80 MongoDB\Driver\ReadPreference: var_export() [tests/readPreference/readpreference-var_export-001.phpt]
81 MongoDB\Driver\Session with wrong defaultTransactionOptions [tests/session/session_error-001.phpt]
82 EOF
83
84 %build
85 get_version() {
86         local define="$1" filename="$2"
87         awk -vdefine="$define" '/#define/ && $2 == define {print $3}' "$filename" | xargs
88 }
89 # Sanity check, really often broken
90 extver=$(get_version PHP_MONGODB_VERSION phongo_version.h)
91 if test "x${extver}" != "x%{version}"; then
92         : Error: Upstream extension version is ${extver}, expecting %{version}.
93         exit 1
94 fi
95
96 phpize
97
98 %configure \
99         --with-libbson=%{?with_bundled:no}%{!?with_bundled:yes} \
100         --with-libmongoc=%{?with_bundled:no}%{!?with_bundled:yes} \
101         --with-mongodb-ssl=%{!?with_ssl:no}%{?with_ssl:openssl} \
102         --with-mongodb-sasl=%{!?with_sasl:no}%{?with_sasl:yes} \
103         --enable-mongodb
104
105 %{__make}
106
107 # simple module load test, always enabled
108 %{__php} -n -q \
109         -d extension_dir=modules \
110         -d extension=%{php_extensiondir}/pcre.so \
111         -d extension=%{php_extensiondir}/spl.so \
112         -d extension=%{php_extensiondir}/json.so \
113         -d extension=%{modname}.so \
114         -m > modules.log
115 grep %{modname} modules.log
116
117 %if %{with tests}
118 cat <<'EOF' > run-tests.sh
119 #!/bin/sh
120 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
121 exec %{__make} test \
122         PHP_EXECUTABLE=%{__php} \
123         PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl json" \
124         RUN_TESTS_SETTINGS="-q $*"
125 EOF
126 chmod +x run-tests.sh
127
128 ./run-tests.sh
129 %endif
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 %{__make} install \
134         EXTENSION_DIR=%{php_extensiondir} \
135         INSTALL_ROOT=$RPM_BUILD_ROOT
136
137 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
138 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
146 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.084751 seconds and 2 git commands to generate.