]> git.pld-linux.org Git - packages/php-pecl-mnogosearch.git/blob - php-pecl-mnogosearch.spec
7973001d8937f909d90b3c45d18589fce331529c
[packages/php-pecl-mnogosearch.git] / php-pecl-mnogosearch.spec
1 %define         _modname        mnogosearch
2 %define         _status         alpha
3 Summary:        %{_modname} - mnoGoSearch extension module for PHP
4 Summary(pl):    %{_modname} - modu³ mnoGoSearch dla PHP
5 Name:           php-pecl-%{_modname}
6 Version:        1.0.0
7 Release:        1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  07fa9afd0c6fa4a3772f84a0eb4f1965
12 URL:            http://pecl.php.net/package/mnogosearch/
13 BuildRequires:  mnogosearch-devel
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 Obsoletes:      php-mnogosearch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Until PHP 5.1.0, this package was bundled in PHP.
23
24 This extension is a complete PHP binding for the mnoGoSearch API. For
25 details please see to http://www.mnogosearch.org/ or the manual.
26
27 In PECL status of this extension is: %{_status}.
28
29 %description -l pl
30 Do wersji PHP 5.1.0, to rozszerzenie by³o czê¶ci± PHP.
31
32 Rozszerzenie to jest kompletnym zestawem dowi±zañ PHP do API
33 mnoGoSearch. Dok³adne informacje dostêpne s± pod adresem
34 http://www.mnogosearch.org/ lub w podrêczniku.
35
36 To rozszerzenie ma w PECL status: %{_status}.
37
38 %prep
39 %setup -q -c
40
41 %build
42 cd %{_modname}-%{version}
43 phpize
44 %configure \
45         --with-mnogosearch=shared,/usr
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
51
52 %{__make} install \
53         -C %{_modname}-%{version} \
54         INSTALL_ROOT=$RPM_BUILD_ROOT \
55         EXTENSION_DIR=%{php_extensiondir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
57 ; Enable %{_modname} extension module
58 extension=%{_modname}.so
59 EOF
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %php_webserver_restart
66
67 %postun
68 if [ "$1" = 0 ]; then
69         %php_webserver_restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc %{_modname}-%{version}/CREDITS
75 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
76 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.059371 seconds and 2 git commands to generate.